summaryrefslogtreecommitdiffstats
path: root/graphics/mirage/mirage.SlackBuild
diff options
context:
space:
mode:
author Ryan P.C. McQuen2014-08-18 13:44:35 +0200
committer Willy Sudiarto Raharjo2014-08-19 11:39:23 +0200
commitb1c18ce62b98fd0222cc75ba6eb62abf750131a4 (patch)
tree1dec72e86723849ad3f94fb94d093ce102e24afa /graphics/mirage/mirage.SlackBuild
parentd4a917d83a593f8d1e4d79bb96c97ae6a4aaae72 (diff)
downloadslackbuilds-b1c18ce62b98fd0222cc75ba6eb62abf750131a4.tar.gz
graphics/mirage: Updated for version 1.0_pre2 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/mirage/mirage.SlackBuild')
-rw-r--r--graphics/mirage/mirage.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/graphics/mirage/mirage.SlackBuild b/graphics/mirage/mirage.SlackBuild
index dc931e52aa..8d297b20ca 100644
--- a/graphics/mirage/mirage.SlackBuild
+++ b/graphics/mirage/mirage.SlackBuild
@@ -2,6 +2,8 @@
# Slackware build script for Mirage
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2010, 2011, 2013 Binh Nguyen <binhvng@gmail.com>
# All rights reserved.
@@ -24,8 +26,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mirage
-VERSION=${VERSION:-0.9.5.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.0_pre2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,14 +53,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root $PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION