summaryrefslogtreecommitdiffstats
path: root/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
diff options
context:
space:
mode:
author Matteo Bernardini2022-09-25 19:20:27 +0200
committer Matteo Bernardini2022-09-25 19:20:27 +0200
commita55c7b30da91ad9cf19740309ec07c78b4da8964 (patch)
tree7d1bbb69ce004905f15d88103da3793018807def /graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
parent05398cdce37f0abbbf3f107ac7cc11a86ad3e7c7 (diff)
downloadslackbuilds-a55c7b30da91ad9cf19740309ec07c78b4da8964.tar.gz
20220925.1 global branch merge.current-20220925.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch')
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
new file mode 100644
index 0000000000..5564ebadc9
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
@@ -0,0 +1,22 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:53:19.496802424 +0200
+@@ -5,19 +5,6 @@
+ CMAKE_POLICY(SET CMP0053 NEW)
+ PROJECT("Luminance HDR")
+
+-string(TOLOWER ${CMAKE_BUILD_TYPE} LOWERCASE_CMAKE_BUILD_TYPE)
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(debug|release|relwithdebinfo|minsizerel)$")
+- message(STATUS "CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
+-else()
+- message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}\n"
+- "CMAKE_BUILD_TYPE should be one of:\nDebug, Release, RelWithDebInfo, MinSizeRel")
+-endif()
+-
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(release|minsizerel)$")
+- message(STATUS "Adding definitions: -DQT_NO_DEBUG_OUTPUT")
+- add_definitions("-DQT_NO_DEBUG_OUTPUT")
+-endif()
+-
+ # assume built-in pthreads on MacOS
+ IF(APPLE)
+ enable_language(CXX)