summaryrefslogtreecommitdiffstats
path: root/graphics/imgmin
diff options
context:
space:
mode:
author B. Watson2022-02-26 21:32:13 +0100
committer Robby Workman2022-02-28 05:27:51 +0100
commit93034363aed905fb7eea0d278b9b1da93f56f443 (patch)
treec2321bdbd8d2e1c513c6348f9ff9c32cca0c7226 /graphics/imgmin
parent17739efa5ae4cb752857591778062a219439930d (diff)
downloadslackbuilds-93034363aed905fb7eea0d278b9b1da93f56f443.tar.gz
graphics/imgmin: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'graphics/imgmin')
-rw-r--r--graphics/imgmin/imgmin.SlackBuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/graphics/imgmin/imgmin.SlackBuild b/graphics/imgmin/imgmin.SlackBuild
index 70922085bd..78cb8732b7 100644
--- a/graphics/imgmin/imgmin.SlackBuild
+++ b/graphics/imgmin/imgmin.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=imgmin
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +74,26 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220226 bkw: ImageMagick API changed between releases 6 and 7.
+sed -i -e 's,<wand/,<MagickWand/,' \
+ -e 's,Matte,Alpha,g' \
+ src/imgmin.[ch]
+
+# 20220226 bkw: the Apache module wouldnt't build, and there's no
+# --disable option. Disable it, thus:
+sed -i 's,\<apxs,XXX-apxs,g' configure.ac
+
+# ...but actually we could make it build. Problem is, apxs chokes if
+# -fopenmp shows up in its arguments. Upstream git adds a sed
+# command to remove it, but it doesn't quite work (because we have
+# -fopenmp twice, and they don't use a global replacement). Fix:
+### sed -i 's,|,|sed "s/-fopenmp *//g"|,' src/apache2/Makefile.am
+# ...but 'make install' doesn't actually install the Apache module,
+# so I went with disabling it. Leave this here for reference.
autoreconf -vif
@@ -89,10 +105,7 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE-MIT.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION