summaryrefslogtreecommitdiffstats
path: root/graphics/fontmatrix/fontmatrix.SlackBuild
diff options
context:
space:
mode:
author Klaatu2016-12-19 00:37:47 +0100
committer Willy Sudiarto Raharjo2016-12-24 01:33:34 +0100
commitfc202df9fc27c18a225194e2e00c0908b54d3ea5 (patch)
tree0496d054f1b85a32a2111831951218e6909fd029 /graphics/fontmatrix/fontmatrix.SlackBuild
parentad1d332ffd6601b52e3c03f23ebda73cb798cde3 (diff)
downloadslackbuilds-fc202df9fc27c18a225194e2e00c0908b54d3ea5.tar.gz
graphics/fontmatrix: Updated for version 20161216.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/fontmatrix/fontmatrix.SlackBuild')
-rw-r--r--graphics/fontmatrix/fontmatrix.SlackBuild45
1 files changed, 14 insertions, 31 deletions
diff --git a/graphics/fontmatrix/fontmatrix.SlackBuild b/graphics/fontmatrix/fontmatrix.SlackBuild
index 3919641d27..7a7eb49dfd 100644
--- a/graphics/fontmatrix/fontmatrix.SlackBuild
+++ b/graphics/fontmatrix/fontmatrix.SlackBuild
@@ -5,13 +5,13 @@
# Maintained by Klaatu <klaatu@member.fsf.org>
PRGNAM=fontmatrix
-VERSION=${VERSION:-r1220}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20161216}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +22,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -41,44 +41,27 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION-Source
-tar xvf $CWD/$PRGNAM-$VERSION-Source.tar.?z*
-cd $PRGNAM-$VERSION-Source
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix the desktop menu item and location of man files.
-echo "StartupNotify=false" >> $PRGNAM.desktop
sed -i 's|share/man|man|' CMakeLists.txt
-# Fix fontmatrix build against icu 0.56.
-patch -p1 < $CWD/fontmatrix-0.9.99-adapt-to-icu-56.patch
-
# Cmake uses the static python lib. Let's use the shared lib instead.
PYVER=$(python -c 'import sys; print sys.version[:3]')
PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"
-# Decide if we want PODOFO support (default is no).
-if [ "${HAVE_PODOFO:-no}" == "yes" ]; then
- USE_PODOFO="TRUE"
-else
- USE_PODOFO="FALSE"
-fi
-
mkdir build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DPYTHON_LIBRARY:PATH="$PY_LIB_SHARED" \
- -DCMAKE_SKIP_RPATH:BOOL=1 \
- -DWANT_ICU:BOOL=true \
-DWANT_M17N:BOOL=true \
- -DWANT_PYTHONQT:BOOL=true \
- -DWANT_PODOFO:BOOL="$USE_PODOFO" \
+ -DWANT_PODOFO:BOOL=true \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_BUILD_TYPE=Release ..
@@ -86,7 +69,7 @@ mkdir build && cd build
# Remove -O3 flag.
for i in $(find . -name "flags.make"); do
sed -i 's|-O3||g' $i
- done
+ done || echo "not needed"
make VERBOSE=1
make install DESTDIR=$PKG