summaryrefslogtreecommitdiffstats
path: root/graphics/fontmatrix/fontmatrix.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2010-05-13 00:27:53 +0200
committer Robby Workman2010-05-13 00:27:53 +0200
commitc93e2543de4efbd52194b2bcc4a091bba1d8b375 (patch)
tree4e352330c767a643cfb9c903ee0cfccee8c97be4 /graphics/fontmatrix/fontmatrix.SlackBuild
parent372fa4524c0d2e956bb36642c0f25a04db1a4121 (diff)
downloadslackbuilds-c93e2543de4efbd52194b2bcc4a091bba1d8b375.tar.gz
graphics/fontmatrix: Updated for version 0.6.0
Diffstat (limited to 'graphics/fontmatrix/fontmatrix.SlackBuild')
-rw-r--r--graphics/fontmatrix/fontmatrix.SlackBuild53
1 files changed, 46 insertions, 7 deletions
diff --git a/graphics/fontmatrix/fontmatrix.SlackBuild b/graphics/fontmatrix/fontmatrix.SlackBuild
index d0164c4db4..af450f435d 100644
--- a/graphics/fontmatrix/fontmatrix.SlackBuild
+++ b/graphics/fontmatrix/fontmatrix.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=fontmatrix
-VERSION=${VERSION:-0.4.2}
+VERSION=${VERSION:-0.6.0}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -26,6 +26,10 @@ elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
+# Decide if we compile fontmatrix with icu4c and/or podofo support. Default is no.
+HAVE_ICU=${HAVE_ICU:-no}
+HAVE_PODOFO=${HAVE_PODOFO:-no}
+
set -e
rm -rf $PKG
@@ -41,20 +45,50 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix the desktop menu item.
-echo "" >> $PRGNAM.desktop
+# Fix the desktop menu item, location of man files, and PODOFO lib64 detection.
echo "StartupNotify=false" >> $PRGNAM.desktop
+sed -i 's|share/man|man|' CMakeLists.txt
+patch -p1 < $CWD/fix-podofo-detection.patch
+# Cmake uses the static python lib. Let's use the shared lib instead.
+PYVER=$(python -c 'import sys; print sys.version[:3]')
+PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"
+
+# Decide if we use ICU.
+if [ "${HAVE_ICU}" == "yes" ]; then
+ USE_ICU="TRUE"
+else
+ USE_ICU="FALSE"
+fi
+
+# Decide if we use PODOFO.
+if [ "${HAVE_PODOFO}" == "yes" ]; then
+ USE_PODOFO="TRUE"
+else
+ USE_PODOFO="FALSE"
+fi
mkdir build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DOWN_SHAPER=1 \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DPYTHON_LIBRARY:PATH="$PY_LIB_SHARED" \
+ -DOWN_SHAPER:BOOL=1 \
-DCMAKE_SKIP_RPATH:BOOL=1 \
-DRPATH_STYLE:STRING=none \
+ -DWANT_ICU:BOOL="$USE_ICU" \
+ -DWANT_M17N:BOOL=true \
+ -DWANT_PYTHONQT:BOOL=true \
+ -DWANT_PODOFO:BOOL="$USE_PODOFO" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" ..
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ # Remove -O3 flag.
+ for i in $(find . -name "flags.make"); do
+ sed -i 's|-O3||g' $i
+ done
- make
+ make VERBOSE=1
make install DESTDIR=$PKG
cd ..
@@ -65,6 +99,11 @@ cd ..
xargs strip --strip-unneeded 2> /dev/null
)
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
rm -rf $PKG/usr/share/icons
for i in 16 22 32 48 64 128; do
mkdir -p $PKG/usr/share/icons/hicolor/${i}x${i}/apps
@@ -85,4 +124,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}