summaryrefslogtreecommitdiffstats
path: root/graphics/FreeCAD
diff options
context:
space:
mode:
author Matteo Bernardini2018-07-28 07:58:42 +0200
committer Matteo Bernardini2018-07-28 07:58:42 +0200
commiteb9f09f3aa50f7ba72b87af629558f74d5be6d10 (patch)
treec1c2c71c4a37f5fca8c5f677d996b2113f71c3bb /graphics/FreeCAD
parentdfc1e15955c74e1614673fed21a3b14a27b6bbcc (diff)
downloadslackbuilds-a6baba4882bac756b94c1d18e39cbbebc9bfe031.tar.gz
20180728.1 global branch merge.current-20180728.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/FreeCAD')
-rw-r--r--graphics/FreeCAD/FreeCAD.SlackBuild3
-rw-r--r--graphics/FreeCAD/find_boost_python_syntax.patch24
2 files changed, 27 insertions, 0 deletions
diff --git a/graphics/FreeCAD/FreeCAD.SlackBuild b/graphics/FreeCAD/FreeCAD.SlackBuild
index 47b0dc08e9..65cad2f47e 100644
--- a/graphics/FreeCAD/FreeCAD.SlackBuild
+++ b/graphics/FreeCAD/FreeCAD.SlackBuild
@@ -84,6 +84,9 @@ else
exit 1
fi
+# Needed for the newer boost
+patch -p1 < $CWD/find_boost_python_syntax.patch
+
mkdir build
cd build
cmake \
diff --git a/graphics/FreeCAD/find_boost_python_syntax.patch b/graphics/FreeCAD/find_boost_python_syntax.patch
new file mode 100644
index 0000000000..dfcf14b20d
--- /dev/null
+++ b/graphics/FreeCAD/find_boost_python_syntax.patch
@@ -0,0 +1,24 @@
+Matteo Bernardini <ponce@slackbuilds.org>
+- - -
+Fix for the newer cmake routine to find boost_python libraries,
+see /usr/share/cmake-3.11/Modules/FindBoost.cmake
+
+diff -Naur FreeCAD-0.17.orig/src/Mod/Path/libarea/CMakeLists.txt FreeCAD-0.17/src/Mod/Path/libarea/CMakeLists.txt
+--- FreeCAD-0.17.orig/src/Mod/Path/libarea/CMakeLists.txt 2018-04-06 10:48:37.000000000 +0200
++++ FreeCAD-0.17/src/Mod/Path/libarea/CMakeLists.txt 2018-05-08 12:32:38.690601000 +0200
+@@ -17,12 +17,12 @@
+ if(USE_BOOST_PYTHON)
+ if(NOT FREECAD_LIBPACK_USE OR FREECAD_LIBPACK_CHECKFILE_CLBUNDLER)
+ if(NOT PYTHON_VERSION_MAJOR LESS 3)
+- find_package( Boost COMPONENTS python3)
++ find_package( Boost COMPONENTS python36)
+ if (NOT Boost_PYTHON3_FOUND)
+- find_package( Boost COMPONENTS python REQUIRED)
++ find_package( Boost COMPONENTS python27 REQUIRED)
+ endif()
+ else()
+- find_package( Boost COMPONENTS python REQUIRED) # find BOOST and boost-python
++ find_package( Boost COMPONENTS python27 REQUIRED) # find BOOST and boost-python
+ endif()
+
+ if(Boost_FOUND)