summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author ArTourter2022-03-05 02:10:10 +0100
committer Willy Sudiarto Raharjo2022-03-05 16:41:38 +0100
commit07262d6485ae23d7f6479868c90030d6861db4a2 (patch)
tree2298e6cb1561d68fcdcf2c2f968847899eda666d /gis
parent82d0cbadbee9b81b92f5c545c71a00ccf400061f (diff)
downloadslackbuilds-07262d6485ae23d7f6479868c90030d6861db4a2.tar.gz
gis/python3-xarray: renamed from python/xarray and updated for version 2022.03.0
This is very much a gis package and is python3 only so rename now before other packages start depending on it. Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-xarray/README9
-rw-r--r--gis/python3-xarray/python3-xarray.SlackBuild100
-rw-r--r--gis/python3-xarray/python3-xarray.info10
-rw-r--r--gis/python3-xarray/slack-desc19
4 files changed, 138 insertions, 0 deletions
diff --git a/gis/python3-xarray/README b/gis/python3-xarray/README
new file mode 100644
index 0000000000..9b2f842138
--- /dev/null
+++ b/gis/python3-xarray/README
@@ -0,0 +1,9 @@
+xarray is an open source project and Python package that aims to bring the
+labeled data power of pandas to the physical sciences, by providing
+N-dimensional variants of the core pandas data structures.
+
+The goal is to provide a pandas-like and pandas-compatible toolkit for
+analytics on multi-dimensional arrays, rather than the tabular data for which
+pandas excels. Our approach adopts the Common Data Model for self- describing
+scientific data in widespread use in the Earth sciences: xarray.Dataset is an
+in-memory representation of a netCDF file.
diff --git a/gis/python3-xarray/python3-xarray.SlackBuild b/gis/python3-xarray/python3-xarray.SlackBuild
new file mode 100644
index 0000000000..b207e37591
--- /dev/null
+++ b/gis/python3-xarray/python3-xarray.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-xarray
+
+# Copyright 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022 Gregory J. L. Tourte <artourter@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-xarray
+VERSION=${VERSION:-2022.03.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=xarray
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CITATION.cff CODE_OF_CONDUCT.md CONTRIBUTING.md HOW_TO_RELEASE.md LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/python3-xarray/python3-xarray.info b/gis/python3-xarray/python3-xarray.info
new file mode 100644
index 0000000000..ef15e83bb5
--- /dev/null
+++ b/gis/python3-xarray/python3-xarray.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-xarray"
+VERSION="2022.03.0"
+HOMEPAGE="http://xarray.pydata.org"
+DOWNLOAD="https://github.com/pydata/xarray/archive/v2022.03.0/xarray-2022.03.0.tar.gz"
+MD5SUM="9150b4ad8373e39f62577d64724a1864"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pandas"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
diff --git a/gis/python3-xarray/slack-desc b/gis/python3-xarray/slack-desc
new file mode 100644
index 0000000000..80a5ce8750
--- /dev/null
+++ b/gis/python3-xarray/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-xarray: python3-xarray (N-D labeled arrays and datasets)
+python3-xarray:
+python3-xarray: xarray is an open source project and Python package that aims to
+python3-xarray: bring the labeled data power of pandas to the physical sciences,
+python3-xarray: by providing N-dimensional variants of the core pandas data
+python3-xarray: structures.
+python3-xarray:
+python3-xarray:
+python3-xarray:
+python3-xarray:
+python3-xarray: