summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Capi X2019-11-01 19:14:20 +0100
committer Willy Sudiarto Raharjo2019-11-01 19:14:20 +0100
commitf3f57962cd94235b1f29aa3c5b73a84cbc80e16e (patch)
treebce6ddfb04b30c778043f3d3c0a81d8e2f905417 /gis
parentfdf6869da608a7dcab49455a40d11863b4ddc38c (diff)
downloadslackbuilds-f3f57962cd94235b1f29aa3c5b73a84cbc80e16e.tar.gz
gis/python-pygeos: Added (Python wrapper for geos).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python-pygeos/README4
-rw-r--r--gis/python-pygeos/python-pygeos.SlackBuild88
-rw-r--r--gis/python-pygeos/python-pygeos.info10
-rw-r--r--gis/python-pygeos/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/gis/python-pygeos/README b/gis/python-pygeos/README
new file mode 100644
index 0000000000..b53462215d
--- /dev/null
+++ b/gis/python-pygeos/README
@@ -0,0 +1,4 @@
+PyGEOS is a C/Python library with vectorized geometry functions. The geometry
+operations are done in the open-source geometry library GEOS. PyGEOS wraps
+these operations in NumPy ufuncs providing a performance improvement when
+operating on arrays of geometries.
diff --git a/gis/python-pygeos/python-pygeos.SlackBuild b/gis/python-pygeos/python-pygeos.SlackBuild
new file mode 100644
index 0000000000..b882da8181
--- /dev/null
+++ b/gis/python-pygeos/python-pygeos.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for python-pygeos
+
+# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=pygeos
+PRGNAM=python-$SRCNAM
+VERSION=${VERSION:-0.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/python-pygeos/python-pygeos.info b/gis/python-pygeos/python-pygeos.info
new file mode 100644
index 0000000000..04fabb6247
--- /dev/null
+++ b/gis/python-pygeos/python-pygeos.info
@@ -0,0 +1,10 @@
+PRGNAM="python-pygeos"
+VERSION="0.5"
+HOMEPAGE="https://pygeos.readthedocs.io"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pygeos/pygeos-0.5.tar.gz"
+MD5SUM="f08653606a94b0dea17b7b253bc2f454"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geos numpy3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/python-pygeos/slack-desc b/gis/python-pygeos/slack-desc
new file mode 100644
index 0000000000..344a192198
--- /dev/null
+++ b/gis/python-pygeos/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-pygeos: python-pygeos (Python wrapper for geos)
+python-pygeos:
+python-pygeos: PyGEOS is a C/Python library with vectorized geometry functions. The
+python-pygeos: geometry operations are done in the open-source geometry library
+python-pygeos: GEOS. PyGEOS wraps these operations in NumPy ufuncs providing a
+python-pygeos: performance improvement when operating on arrays of geometries.
+python-pygeos:
+python-pygeos:
+python-pygeos:
+python-pygeos:
+python-pygeos: