summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2020-01-02 02:42:27 +0100
committer Robby Workman2020-01-03 09:11:10 +0100
commita3937548a72e9da471b5239c7678a4f9824edd28 (patch)
tree8a74c1fab0fe80979cf6cbc750835a26505968ae /gis
parent6cb6026ce8b60003cbb4489cb4d72c6581442896 (diff)
downloadslackbuilds-a3937548a72e9da471b5239c7678a4f9824edd28.tar.gz
gis/cartopy: Add support for Python 3.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/cartopy/cartopy.SlackBuild8
-rw-r--r--gis/cartopy/cartopy.info2
2 files changed, 6 insertions, 4 deletions
diff --git a/gis/cartopy/cartopy.SlackBuild b/gis/cartopy/cartopy.SlackBuild
index aa7effe818..c5ff17247c 100644
--- a/gis/cartopy/cartopy.SlackBuild
+++ b/gis/cartopy/cartopy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for cartopy
-# Copyright 2014-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=cartopy
VERSION=${VERSION:-0.17.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1" \
- python setup.py install --root=$PKG
+ python2 setup.py install --root=$PKG
+CFLAGS="$SLKCFLAGS -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1" \
+ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/cartopy/cartopy.info b/gis/cartopy/cartopy.info
index aa20ea5dba..b349b33d46 100644
--- a/gis/cartopy/cartopy.info
+++ b/gis/cartopy/cartopy.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/SciTools/cartopy/archive/v0.17.0/cartopy-0.17.0.tar
MD5SUM="9fe063295a9fd854803d3c01a60720d0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="geos matplotlib proj pyshp scipy Shapely"
+REQUIRES="geos matplotlib python3-matplotlib proj pyshp scipy scipy3 Shapely"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"