summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-02-07 17:51:30 +0100
committer Willy Sudiarto Raharjo2022-02-07 17:51:30 +0100
commitcfa4e17b4a2f34aaefeb8701b740d14273753934 (patch)
tree6db0850fc42a87611b598a31bff1b7c41b70b925 /gis
parentb69c319729206f26ef1db1af360016a121423265 (diff)
downloadslackbuilds-cfa4e17b4a2f34aaefeb8701b740d14273753934.tar.gz
gis/CreateCloudMap: Removed (Service is shut down).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/CreateCloudMap/CreateCloudMap.SlackBuild96
-rw-r--r--gis/CreateCloudMap/CreateCloudMap.info10
-rw-r--r--gis/CreateCloudMap/README5
-rw-r--r--gis/CreateCloudMap/doinst.sh3
-rw-r--r--gis/CreateCloudMap/slack-desc19
5 files changed, 0 insertions, 133 deletions
diff --git a/gis/CreateCloudMap/CreateCloudMap.SlackBuild b/gis/CreateCloudMap/CreateCloudMap.SlackBuild
deleted file mode 100644
index 9562f37cce..0000000000
--- a/gis/CreateCloudMap/CreateCloudMap.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for CreateCloudMap
-
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=CreateCloudMap
-VERSION=${VERSION:-0.9.13}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/CreateCloudMap/CreateCloudMap.info b/gis/CreateCloudMap/CreateCloudMap.info
deleted file mode 100644
index e4a5fa5131..0000000000
--- a/gis/CreateCloudMap/CreateCloudMap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="CreateCloudMap"
-VERSION="0.9.13"
-HOMEPAGE="https://github.com/jmozmoz/cloudmap"
-DOWNLOAD="https://files.pythonhosted.org/packages/1f/5c/75ce03f468e0765120a307da2ccefafe10f7d1cce122de21ae653cbb49af/CreateCloudMap-0.9.13.tar.gz"
-MD5SUM="c7108d2b0fe3413da9c953b9dd99502a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyresample scipy ConfigParser pillowfight"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/gis/CreateCloudMap/README b/gis/CreateCloudMap/README
deleted file mode 100644
index f38ad22afa..0000000000
--- a/gis/CreateCloudMap/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Python script to create a cloud map for xplanet using satellite images from the
-Dundee Satellite Receiving Station, Dundee University, UK.
-
-Optional :
-xplanet can use a cloud map to make the earth look more pretty.
diff --git a/gis/CreateCloudMap/doinst.sh b/gis/CreateCloudMap/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/gis/CreateCloudMap/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/gis/CreateCloudMap/slack-desc b/gis/CreateCloudMap/slack-desc
deleted file mode 100644
index 07404c420e..0000000000
--- a/gis/CreateCloudMap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-CreateCloudMap: CreateCloudMap (cloud map for xplanet)
-CreateCloudMap:
-CreateCloudMap: Python script to create a cloud map for xplanet using satellite
-CreateCloudMap: images from the Dundee Satellite Receiving Station, Dundee
-CreateCloudMap: University, UK.
-CreateCloudMap:
-CreateCloudMap: Homepage: https://github.com/jmozmoz/cloudmap
-CreateCloudMap:
-CreateCloudMap:
-CreateCloudMap:
-CreateCloudMap: