summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2016-02-28 03:21:19 +0100
committer Willy Sudiarto Raharjo2016-03-02 13:12:16 +0100
commit3c8975717e88872577f3e5bbe82a69d636fcbf86 (patch)
tree66022221d7aafb3a524d164fdd5382a4d48f31ec /gis
parent5db00c12eaa705b32368572a385528ee5d8fe4f7 (diff)
downloadslackbuilds-3c8975717e88872577f3e5bbe82a69d636fcbf86.tar.gz
gis/pyspatialite: Added (Python bindings for Spatialite).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis')
-rw-r--r--gis/pyspatialite/README5
-rw-r--r--gis/pyspatialite/pyspatialite.SlackBuild87
-rw-r--r--gis/pyspatialite/pyspatialite.info10
-rw-r--r--gis/pyspatialite/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/gis/pyspatialite/README b/gis/pyspatialite/README
new file mode 100644
index 0000000000..0510b0be8f
--- /dev/null
+++ b/gis/pyspatialite/README
@@ -0,0 +1,5 @@
+pyspatialite is an interface to the SQLite 3.x embedded relational database
+engine with spatialite extensions.
+
+It is almost fully compliant with the Python database API version 2.0 and also
+exposes the unique features of SQLite and spatialite.
diff --git a/gis/pyspatialite/pyspatialite.SlackBuild b/gis/pyspatialite/pyspatialite.SlackBuild
new file mode 100644
index 0000000000..f43bc6cbe4
--- /dev/null
+++ b/gis/pyspatialite/pyspatialite.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for pyspatialite
+
+# Copyright 2016 Benjamin Trigona-Harany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyspatialite
+VERSION=${VERSION:-3.0.1_alpha_0}
+SRCVER=$(echo $VERSION | tr '_' '-')
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${SRCVER}
+tar xvf $CWD/$PRGNAM-${SRCVER}.tar.gz || tar xvf $CWD/${SRCVER}.tar.gz
+cd $PRGNAM-${SRCVER}
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS=-I/usr/include python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -r $PKG/usr/$PRGNAM-doc
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/pyspatialite/pyspatialite.info b/gis/pyspatialite/pyspatialite.info
new file mode 100644
index 0000000000..abb97908bd
--- /dev/null
+++ b/gis/pyspatialite/pyspatialite.info
@@ -0,0 +1,10 @@
+PRGNAM="pyspatialite"
+VERSION="3.0.1_alpha_0"
+HOMEPAGE="https://github.com/lokkju/pyspatialite"
+DOWNLOAD="https://github.com/lokkju/pyspatialite/archive/3.0.1-alpha-0.tar.gz"
+MD5SUM="d4b9364756b90bc81399fea27af9dc98"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libspatialite"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/pyspatialite/slack-desc b/gis/pyspatialite/slack-desc
new file mode 100644
index 0000000000..642887e80f
--- /dev/null
+++ b/gis/pyspatialite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyspatialite: pyspatialite (Python bindings for Spatialite)
+pyspatialite:
+pyspatialite: pyspatialite is an interface to the SQLite 3.x embedded relational
+pyspatialite: database engine with spatialite extensions.
+pyspatialite:
+pyspatialite: It is almost fully compliant with the Python database API version
+pyspatialite: 2.0 and also exposes the unique features of SQLite and spatialite.
+pyspatialite:
+pyspatialite:
+pyspatialite:
+pyspatialite: