summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2014-04-10 16:11:18 +0200
committer Willy Sudiarto Raharjo2014-04-10 19:46:48 +0200
commiteaec78099c01ea762d405ee04969b27230beae7f (patch)
tree200cd042ecf9b2b60c7e290f7715cb2a9521c33f /gis
parent567fbbdacdf4544c913fd3dc48ad68ad99d51abc (diff)
downloadslackbuilds-eaec78099c01ea762d405ee04969b27230beae7f.tar.gz
gis/pyshp: Added (Python shapefile manipulation library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/pyshp/README4
-rw-r--r--gis/pyshp/pyshp.SlackBuild89
-rw-r--r--gis/pyshp/pyshp.info10
-rw-r--r--gis/pyshp/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/gis/pyshp/README b/gis/pyshp/README
new file mode 100644
index 0000000000..47bdcfc2cc
--- /dev/null
+++ b/gis/pyshp/README
@@ -0,0 +1,4 @@
+The pyshp library reads and writes ESRI Shapefiles in pure Python. You can read
+and write shp, shx, and dbf files with all types of geometry. Everything in the
+public ESRI shapefile specification is implemented. This library is compatible
+with Python versions 2.4 to 3.x.
diff --git a/gis/pyshp/pyshp.SlackBuild b/gis/pyshp/pyshp.SlackBuild
new file mode 100644
index 0000000000..3e71164dc9
--- /dev/null
+++ b/gis/pyshp/pyshp.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for pyshp
+
+# Copyright 2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyshp
+VERSION=${VERSION:-1.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -e $CWD/v$VERSION.tar.gz ]; then
+ tar xvf $CWD/v$VERSION.tar.gz
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a changelog.txt README.txt README.pdf $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/pyshp/pyshp.info b/gis/pyshp/pyshp.info
new file mode 100644
index 0000000000..287fd8083e
--- /dev/null
+++ b/gis/pyshp/pyshp.info
@@ -0,0 +1,10 @@
+PRGNAM="pyshp"
+VERSION="1.2.0"
+HOMEPAGE="http://code.google.com/p/pyshp/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyshp/pyshp-1.2.0.tar.gz"
+MD5SUM="9075f34109f0bb4b45a90fd1fb5db94b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/pyshp/slack-desc b/gis/pyshp/slack-desc
new file mode 100644
index 0000000000..adbd0e052f
--- /dev/null
+++ b/gis/pyshp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyshp: pyshp (Python shapefile manipulation library)
+pyshp:
+pyshp: This library reads and writes ESRI Shapefiles in pure Python. You can
+pyshp: read and write shp, shx, and dbf files with all types of geometry.
+pyshp: Everything in the public ESRI shapefile specification is implemented.
+pyshp: This library is compatible with Python versions 2.4 to 3.x.
+pyshp:
+pyshp:
+pyshp:
+pyshp:
+pyshp: