summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2014-02-02 00:32:56 +0100
committer Robby Workman2014-02-02 09:09:46 +0100
commit26d06b1544168e3d8f7a3d4b97c9e7045aefe07f (patch)
tree93ff43485f1b18fa8531ab0eb43f8daa47078f48 /gis
parent9d2b3ac67408a16865da3c87ca7a058ba1936f13 (diff)
downloadslackbuilds-26d06b1544168e3d8f7a3d4b97c9e7045aefe07f.tar.gz
gis/Fiona: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/Fiona/Fiona.SlackBuild89
-rw-r--r--gis/Fiona/Fiona.info10
-rw-r--r--gis/Fiona/README9
-rw-r--r--gis/Fiona/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/gis/Fiona/Fiona.SlackBuild b/gis/Fiona/Fiona.SlackBuild
new file mode 100644
index 0000000000..3f378fb15b
--- /dev/null
+++ b/gis/Fiona/Fiona.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for Fiona
+
+# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Fiona
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -e $CWD/$VERSION.tar.gz ]; then
+ tar xvf $CWD/$VERSION.tar.gz
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt CREDITS.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/Fiona/Fiona.info b/gis/Fiona/Fiona.info
new file mode 100644
index 0000000000..65f973d263
--- /dev/null
+++ b/gis/Fiona/Fiona.info
@@ -0,0 +1,10 @@
+PRGNAM="Fiona"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/Toblerity/Fiona"
+DOWNLOAD="https://github.com/Toblerity/Fiona/archive/1.0.2.tar.gz"
+MD5SUM="1bc75d0578106ba81d625727e3620725"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="Cython gdal six"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/Fiona/README b/gis/Fiona/README
new file mode 100644
index 0000000000..d079aa2700
--- /dev/null
+++ b/gis/Fiona/README
@@ -0,0 +1,9 @@
+Fiona provides uncomplicated Python interfaces to functions in OGR, the best
+open source C/C++ library for reading and writing geographic vector data.
+
+Fiona is designed to be simple and dependable. It focuses on reading and
+writing data in standard Python IO style, and relies upon familiar Python types
+and protocols such as files, dictionaries, mappings, and iterators instead of
+classes specific to OGR. Fiona can read and write real-world data using
+multi-layered GIS formats and zipped virtual file systems and integrates
+readily with other Python GIS packages such as pyproj, Rtree and Shapely.
diff --git a/gis/Fiona/slack-desc b/gis/Fiona/slack-desc
new file mode 100644
index 0000000000..f129f8bff8
--- /dev/null
+++ b/gis/Fiona/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Fiona: Fiona (Python interface for OGR)
+Fiona:
+Fiona: Fiona provides uncomplicated Python interfaces to functions in OGR,
+Fiona: the best open source C/C++ library for reading and writing geographic
+Fiona: vector data.
+Fiona:
+Fiona: Homepage: https://github.com/Toblerity/Fiona
+Fiona:
+Fiona:
+Fiona:
+Fiona: