summaryrefslogtreecommitdiffstats
path: root/gis/Shapely/Shapely.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-02-22 22:13:21 +0100
committer Willy Sudiarto Raharjo2019-02-23 02:26:53 +0100
commitd945102b2af611e952f1457b91b70f4e4ed4d856 (patch)
treead697a4c23b0276981be6ab1df22e7bf9abdc9a9 /gis/Shapely/Shapely.SlackBuild
parent4197c5da09b6360495d85fb45609597b63eba128 (diff)
downloadslackbuilds-d945102b2af611e952f1457b91b70f4e4ed4d856.tar.gz
gis/Shapely: Enable Python 3 by default.
Diffstat (limited to 'gis/Shapely/Shapely.SlackBuild')
-rw-r--r--gis/Shapely/Shapely.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/gis/Shapely/Shapely.SlackBuild b/gis/Shapely/Shapely.SlackBuild
index 86856a927d..5af6caefb4 100644
--- a/gis/Shapely/Shapely.SlackBuild
+++ b/gis/Shapely/Shapely.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Shapely
-# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=Shapely
VERSION=${VERSION:-1.6.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,10 +72,8 @@ find -L . \
# remove unnecessary .pxi file
sed -i "s/data_files\s*=.*/data_files = [],/g" setup.py
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true