summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2022-02-08 06:20:05 +0100
committer Willy Sudiarto Raharjo2022-02-09 03:35:14 +0100
commitd79cdc76b753f3f08b6016eadb1d778a3de7c1d1 (patch)
tree3516b59abec4a685931c21a6e2d5815ab17413bb /games
parent72183c362bad0598e6167de71c091e9733e1901b (diff)
downloadslackbuilds-d79cdc76b753f3f08b6016eadb1d778a3de7c1d1.tar.gz
games/odamex: Add missing diff.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/odamex/odamex.SlackBuild3
-rw-r--r--games/odamex/use_bundled_portmidi.diff20
2 files changed, 22 insertions, 1 deletions
diff --git a/games/odamex/odamex.SlackBuild b/games/odamex/odamex.SlackBuild
index 8ddcc1ffe4..11784389de 100644
--- a/games/odamex/odamex.SlackBuild
+++ b/games/odamex/odamex.SlackBuild
@@ -6,6 +6,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20220208 bkw: BUILD=3, add the missing .diff...
# 20211231 bkw: BUILD=2.
# - the SDL2 segfault will likely be fixed soon (reported to PV, along
# with a patch). add SDL2 environment variable, default to no.
@@ -32,7 +33,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=odamex
VERSION=${VERSION:-0.9.5}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/games/odamex/use_bundled_portmidi.diff b/games/odamex/use_bundled_portmidi.diff
new file mode 100644
index 0000000000..2fffcc2737
--- /dev/null
+++ b/games/odamex/use_bundled_portmidi.diff
@@ -0,0 +1,20 @@
+diff -Naur odamex-src-0.9.5/client/CMakeLists.txt odamex-src-0.9.5.patched/client/CMakeLists.txt
+--- odamex-src-0.9.5/client/CMakeLists.txt 2021-09-08 23:18:23.000000000 -0400
++++ odamex-src-0.9.5.patched/client/CMakeLists.txt 2022-01-01 14:36:43.305448361 -0500
+@@ -65,8 +65,6 @@
+
+ # PortMidi
+ if(ENABLE_PORTMIDI)
+- find_package(PortMidi)
+- if(NOT PORTMIDI_FOUND)
+ # build the PortMidi library
+ set(PORTMIDI_LIBRARY "portmidi")
+ set(PORTMIDI_LIBRARIES ${PORTMIDI_LIBRARY})
+@@ -107,7 +105,6 @@
+ add_library(${PORTMIDI_LIBRARY} STATIC ${PORTMIDI_SOURCES} ${PORTMIDI_HEADERS})
+ target_link_libraries(${PORTMIDI_LIBRARY} ${PM_NEEDED_LIBS})
+ message(STATUS "portmidi will be built and staticaly linked when compiling the client application.")
+- endif()
+
+ add_definitions(-DPORTMIDI)
+ include_directories(${PORTMIDI_INCLUDE_DIR})