summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-02-07 18:19:55 +0100
committer Willy Sudiarto Raharjo2022-02-08 04:28:32 +0100
commit72005ca8bf834116e07d0aca44161684df7dc69b (patch)
tree95cab9036b444fb716e1d94cbe813e125d4b5af3 /games
parentdff7c85eef13f16ada611af0dd5b1d6d723d0f62 (diff)
downloadslackbuilds-72005ca8bf834116e07d0aca44161684df7dc69b.tar.gz
games/rejoystick: Removed (no maintainer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/rejoystick/README5
-rw-r--r--games/rejoystick/rejoystick.SlackBuild94
-rw-r--r--games/rejoystick/rejoystick.info10
-rw-r--r--games/rejoystick/rejoystick.patch19
-rw-r--r--games/rejoystick/slack-desc19
5 files changed, 0 insertions, 147 deletions
diff --git a/games/rejoystick/README b/games/rejoystick/README
deleted file mode 100644
index 1a58bee65a..0000000000
--- a/games/rejoystick/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Rejoystick is a program that maps keypresses on your
-gamepad/joypad/joystick to keypresses on a keyboard when you
-are running X. Since it uses SDL to communicate with the gamepad
-device, it can work on every platform that provides SDL and an
-X environment. (Though it is yet to be tested on Cygwin e.g.)
diff --git a/games/rejoystick/rejoystick.SlackBuild b/games/rejoystick/rejoystick.SlackBuild
deleted file mode 100644
index 75787ecac2..0000000000
--- a/games/rejoystick/rejoystick.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for rejoystick
-
-# Written by Steven Pledger <linux.propane@yahoo.com>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=rejoystick
-VERSION=${VERSION:-0.8.1}
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Specify the path to the version.mk file inside of the configure script
-sed -i "s|^\.\ version\.mk|. ./version.mk|" configure
-
-patch -p1 < $CWD/rejoystick.patch
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# AUTHORS, ChangeLog, and NEWS are empty files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/rejoystick/rejoystick.info b/games/rejoystick/rejoystick.info
deleted file mode 100644
index 7fbe5951a4..0000000000
--- a/games/rejoystick/rejoystick.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="rejoystick"
-VERSION="0.8.1"
-HOMEPAGE="http://rejoystick.sourceforge.net/"
-DOWNLOAD="http://sourceforge.net/projects/rejoystick/files/rejoystick/rejoystick-0.8.1/rejoystick-0.8.1.tar.gz"
-MD5SUM="43208b766a131e2725bfd72caf60a41d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Steven Pledger"
-EMAIL="linux.propane@yahoo.com"
diff --git a/games/rejoystick/rejoystick.patch b/games/rejoystick/rejoystick.patch
deleted file mode 100644
index a163936aeb..0000000000
--- a/games/rejoystick/rejoystick.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- rejoystick-0.8.1/src/main.c.orig 2014-12-20 06:55:37.951753670 +0700
-+++ rejoystick-0.8.1/src/main.c 2014-12-20 06:56:23.666092712 +0700
-@@ -137,13 +137,9 @@
-
- pthread_t sdl_thread;
-
-- char* home;
-- char* keyfile;
--
-- home = (char*)getenv("HOME");
-- keyfile = KEYFILE;
-- filename = strcat(home, keyfile);
--
-+ const char * home = getenv("HOME");
-+ filename = malloc(strlen(home) + strlen(KEYFILE) + 1);
-+ sprintf(filename, "%s%s", home, KEYFILE);
- global_argv = argv;
-
-
diff --git a/games/rejoystick/slack-desc b/games/rejoystick/slack-desc
deleted file mode 100644
index 674fdf7e11..0000000000
--- a/games/rejoystick/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-rejoystick: rejoystick (translates joystick keypresses to keyboard)
-rejoystick:
-rejoystick: Rejoystick is a program that maps keypresses on your
-rejoystick: gamepad/joypad/joystick to keypresses on a keyboard when you
-rejoystick: are running X. Since it uses SDL to communicate with the gamepad
-rejoystick: device, it can work on every platform that provides SDL and an
-rejoystick: X environment. (Though it is yet to be tested on Cygwin e.g.)
-rejoystick:
-rejoystick: Homepage: http://rejoystick.sourceforge.net/
-rejoystick:
-rejoystick: