summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Christoph Willing2019-06-04 03:12:44 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:31:20 +0200
commit84f7d553543166ee131c3395de05636af7757977 (patch)
tree9965826a955f530dd602312cb17d89f9af9410a5 /games
parent23912da7c9061da3402250ac6b1fc5bea40e8652 (diff)
downloadslackbuilds-84f7d553543166ee131c3395de05636af7757977.tar.gz
games/bluez-sixaxis: Added (Bluetooth plugin for PS3 controller).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/bluez-sixaxis/README10
-rw-r--r--games/bluez-sixaxis/bluez-5.30-obexd_without_systemd-1.patch61
-rw-r--r--games/bluez-sixaxis/bluez-sixaxis.SlackBuild139
-rw-r--r--games/bluez-sixaxis/bluez-sixaxis.info10
-rw-r--r--games/bluez-sixaxis/slack-desc19
5 files changed, 239 insertions, 0 deletions
diff --git a/games/bluez-sixaxis/README b/games/bluez-sixaxis/README
new file mode 100644
index 0000000000..2a4d2b5cd2
--- /dev/null
+++ b/games/bluez-sixaxis/README
@@ -0,0 +1,10 @@
+BlueZ provides support for the core Bluetooth layers and protocols. It is flexible,
+efficient and uses a modular implementation.
+
+This package provides only the sixaxis plugin (missing from the main Slackware
+bluez release). It plugs into the existing bluez package which, as part of main
+Slackware, is expected to be installed already.
+
+To enable the sixaxis plugin after installation, you may need to restart Slackware
+or, at the very least, restart the system bluetooth facililties via the
+/etc./rc.d/rc.bluetooth script.
diff --git a/games/bluez-sixaxis/bluez-5.30-obexd_without_systemd-1.patch b/games/bluez-sixaxis/bluez-5.30-obexd_without_systemd-1.patch
new file mode 100644
index 0000000000..749787c5b3
--- /dev/null
+++ b/games/bluez-sixaxis/bluez-5.30-obexd_without_systemd-1.patch
@@ -0,0 +1,61 @@
+Submitted By: Armin K. <krejzi at email dot com>
+Date: 2013-04-29
+Initial Package Version: 5.17
+Upstream Status: unknown
+Origin: Arch Linux (Giovanni Campagna)
+Description: Allow using obexd without systemd in the user session
+
+Not all sessions run systemd --user (actually, the majority
+doesn't), so the dbus daemon must be able to spawn obexd
+directly, and to do so it needs the full path of the daemon.
+---
+ Makefile.obexd | 4 ++--
+ obexd/src/org.bluez.obex.service | 4 ----
+ obexd/src/org.bluez.obex.service.in | 4 ++++
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+ delete mode 100644 obexd/src/org.bluez.obex.service
+ create mode 100644 obexd/src/org.bluez.obex.service.in
+
+diff --git a/Makefile.obexd b/Makefile.obexd
+index 3760867..142e7c3 100644
+--- a/Makefile.obexd
++++ b/Makefile.obexd
+@@ -2,12 +2,12 @@
+ if SYSTEMD
+ systemduserunitdir = @SYSTEMD_USERUNITDIR@
+ systemduserunit_DATA = obexd/src/obex.service
++endif
+
+ dbussessionbusdir = @DBUS_SESSIONBUSDIR@
+ dbussessionbus_DATA = obexd/src/org.bluez.obex.service
+-endif
+
+-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
++EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
+
+ obex_plugindir = $(libdir)/obex/plugins
+
+diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
+deleted file mode 100644
+index a538088..0000000
+--- a/obexd/src/org.bluez.obex.service
++++ /dev/null
+@@ -1,4 +0,0 @@
+-[D-BUS Service]
+-Name=org.bluez.obex
+-Exec=/bin/false
+-SystemdService=dbus-org.bluez.obex.service
+diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
+new file mode 100644
+index 0000000..9c815f2
+--- /dev/null
++++ b/obexd/src/org.bluez.obex.service.in
+@@ -0,0 +1,4 @@
++[D-BUS Service]
++Name=org.bluez.obex
++Exec=@libexecdir@/obexd
++SystemdService=dbus-org.bluez.obex.service
+--
+1.8.3.1
+
+
diff --git a/games/bluez-sixaxis/bluez-sixaxis.SlackBuild b/games/bluez-sixaxis/bluez-sixaxis.SlackBuild
new file mode 100644
index 0000000000..73abec6ab4
--- /dev/null
+++ b/games/bluez-sixaxis/bluez-sixaxis.SlackBuild
@@ -0,0 +1,139 @@
+#!/bin/sh
+
+# Copyright 2009, 2010, 2011, 2012, 2013, 2016 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+# Changes for SBo, Copyright 2019 Christoph WIlling, Brisbane, Aistralia
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bluez-sixaxis
+SRCNAM=bluez
+VERSION=${VERSION:-5.47}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i586 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/${SRCNAM}-${VERSION}.tar.xz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 --verbose < $CWD/bluez-5.30-obexd_without_systemd-1.patch
+
+autoreconf -vif
+
+sed -i -e 's|-lreadline|\0 -lncursesw|g' Makefile.{in,tools}
+
+# We're adding --enable-deprecated due to this commit:
+#
+# commit b1eb2c4cd057624312e0412f6c4be000f7fc3617
+#Author: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+#Date: Wed Jan 4 14:23:58 2017 +0200
+#
+# build: Hide deprecated tools under --enable-deprecated
+#
+# This marks the following tools as deprecated as they are not longer
+# maintained or have been replaced by other tools:
+#
+# hciattach hciconfig hcitool hcidump rfcomm sdptool ciptool gatttool
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+LDFLAGS="-L/usr/lib$LIBDIRSUFFIX" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --localstatedir=/var \
+ --docdir=/usr/doc/${PRGNAM}-${VERSION} \
+ --enable-library \
+ --disable-systemd \
+ --enable-deprecated \
+ --enable-sixaxis \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Remove everything except the sixaxis plugin
+rm -rf $PKG/etc
+rm -rf $PKG/lib
+rm -rf $PKG/usr/{bin,include,libexec,man,share}
+rm -rf $PKG/usr/lib64/{cups,lib*,pkgconfig}
+
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING* INSTALL README* TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.sixaxis
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PRGNAM}-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/bluez-sixaxis/bluez-sixaxis.info b/games/bluez-sixaxis/bluez-sixaxis.info
new file mode 100644
index 0000000000..8b8096e467
--- /dev/null
+++ b/games/bluez-sixaxis/bluez-sixaxis.info
@@ -0,0 +1,10 @@
+PRGNAM="bluez-sixaxis"
+VERSION="5.47"
+HOMEPAGE="http://www.bluez.org"
+DOWNLOAD="http://www.kernel.org/pub/linux/bluetooth/bluez-5.47.tar.xz"
+MD5SUM="783e15f65e70cdb8f721c659e140dd56"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/games/bluez-sixaxis/slack-desc b/games/bluez-sixaxis/slack-desc
new file mode 100644
index 0000000000..cfa104f628
--- /dev/null
+++ b/games/bluez-sixaxis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+bluez-sixaxis: bluez-sixaxis (Bluetooth plugin for Sony PS3 controller)
+bluez-sixaxis:
+bluez-sixaxis: Bluez is the Bluetooth stack for Linux, allowing Bluetooth adaptors
+bluez-sixaxis: and devices to be used with Linux. This package contains only the
+bluez-sixaxis: Bluez plugin for the Sony PS3 sixaxis controller.
+bluez-sixaxis:
+bluez-sixaxis: For more info, visit: http://www.bluez.org
+bluez-sixaxis:
+bluez-sixaxis:
+bluez-sixaxis:
+bluez-sixaxis: