summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Hunter Sezen2018-12-14 19:15:14 +0100
committer Willy Sudiarto Raharjo2018-12-14 19:15:14 +0100
commitbca53de125baf6a7f3a5c7de62c04944c13e97fd (patch)
tree923467b77608f6f04b5445eaa6fecfdae1863039 /games
parent88686099809b90dc80c21fea5292be8137d4d1a5 (diff)
downloadslackbuilds-bca53de125baf6a7f3a5c7de62c04944c13e97fd.tar.gz
games/pcsx2: Updated for version 2018.12.11_0e43803.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/pcsx2/doinst.sh4
-rw-r--r--games/pcsx2/pcsx2.SlackBuild14
-rw-r--r--games/pcsx2/pcsx2.info6
3 files changed, 17 insertions, 7 deletions
diff --git a/games/pcsx2/doinst.sh b/games/pcsx2/doinst.sh
index e5c312a460..7fe767b718 100644
--- a/games/pcsx2/doinst.sh
+++ b/games/pcsx2/doinst.sh
@@ -7,3 +7,7 @@ if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
/usr/bin/gdk-pixbuf-query-loaders > /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
fi
fi
+
+if [ -x /sbin/setcap ] && [ -f usr/bin/PCSX2 ]; then
+ /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' usr/bin/PCSX2
+fi
diff --git a/games/pcsx2/pcsx2.SlackBuild b/games/pcsx2/pcsx2.SlackBuild
index df919ac0bb..2f5096784e 100644
--- a/games/pcsx2/pcsx2.SlackBuild
+++ b/games/pcsx2/pcsx2.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pcsx2
-VERSION=${VERSION:-2018.05.16_290397d}
+VERSION=${VERSION:-2018.12.11_0e43803}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -92,9 +92,15 @@ fi
[ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
+# Handle this in doinst.sh instead
+# https://github.com/PCSX2/pcsx2/issues/2699
+sed -i '/setcap/d' pcsx2/CMakeLists.txt
+
# Use a font included with Slackware
# osd error: 'Failed to init the freetype face'
-zcat $CWD/osd_font.diff.gz | patch -p1
+sed -i \
+ 's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
+ plugins/GSdx/GSdx.cpp
mkdir -p build
cd build
@@ -121,8 +127,8 @@ cd build
cd ..
if [ "$DEBUG" = 0 ]; then
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
fi
find $PKG/usr/man -type f -exec gzip -9 {} \;
diff --git a/games/pcsx2/pcsx2.info b/games/pcsx2/pcsx2.info
index 4c0fd9761d..0508e9ccd3 100644
--- a/games/pcsx2/pcsx2.info
+++ b/games/pcsx2/pcsx2.info
@@ -1,8 +1,8 @@
PRGNAM="pcsx2"
-VERSION="2018.05.16_290397d"
+VERSION="2018.12.11_0e43803"
HOMEPAGE="https://pcsx2.net"
-DOWNLOAD="http://slackware.uk/sbosrcarch/by-name/games/pcsx2/pcsx2-2018.05.16_290397d.tar.xz"
-MD5SUM="dd4faba347b4c5241b0e1bc7e0f8a128"
+DOWNLOAD="http://slackless.raccoons.tech/src/pcsx2-2018.12.11_0e43803.tar.xz"
+MD5SUM="48af5b3fc0c1a16bd71dd433ea14111e"
DOWNLOAD_x86_64="UNSUPPORTED"
MD5SUM_x86_64=""
REQUIRES="SDL2 wxGTK3 portaudio soundtouch"