summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Johannes Schoepfer2019-04-12 19:45:07 +0200
committer Willy Sudiarto Raharjo2019-04-12 19:45:07 +0200
commit3f7af4e323d1809699a0e8a919167a3fd4d92285 (patch)
tree9bacf9fea4e788df53167c8560c63506f721e7dd /games
parent59c6f412ffdbb1d005d1c555763f65586503a955 (diff)
downloadslackbuilds-3f7af4e323d1809699a0e8a919167a3fd4d92285.tar.gz
games/mednafen: Update script.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/mednafen/mednafen.SlackBuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/mednafen/mednafen.SlackBuild b/games/mednafen/mednafen.SlackBuild
index 65e7e717c8..59d1929e47 100644
--- a/games/mednafen/mednafen.SlackBuild
+++ b/games/mednafen/mednafen.SlackBuild
@@ -70,6 +70,32 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# sanitize build flags
+sed \
+ -e '/-fno-fast-math/d' \
+ -e '/-fno-unsafe-math-optimizations/d' \
+ -e '/-fno-aggressive-loop-optimizations/d' \
+ -e '/-fno-ipa-icf/d' \
+ -e '/-fno-printf-return-value/d' \
+ -e '/-fno-pic/d' \
+ -e '/-fno-pie/d' \
+ -e '/-fno-PIC/d' \
+ -e '/-fno-PIE/d' \
+ -e '/-nopie/d' \
+ -e '/-no-pie/d' \
+ -e '/-fno-stack-protector/d' \
+ -e '/-fno-stack-protector-all/d' \
+ -e '/-fno-stack-protector-strong/d' \
+ -e '/-mtune=haswell/d' \
+ -i configure.ac
+
+# This warning is not true at least on x86_64
+sed -e '/Compiling with position-independent code generation enabled is not recommended, for performance reasons/d' \
+ -i src/types.h
+
+autoreconf
+
+ #--with-external-lzo \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \