summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2022-02-23 18:36:54 +0100
committer Willy Sudiarto Raharjo2022-02-25 16:58:02 +0100
commitcabbc1914deadf9095193a7a49d6ac239ee051de (patch)
tree5ca94ac69fdbe714729dbd686a12930332d36363 /games
parent5bfb3f712c4b0c7ee1edcc439eee6e2f1b7f3eae (diff)
downloadslackbuilds-cabbc1914deadf9095193a7a49d6ac239ee051de.tar.gz
games/mrboom: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/mrboom/mrboom.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/mrboom/mrboom.SlackBuild b/games/mrboom/mrboom.SlackBuild
index 94864b1d4a..82f113fc0d 100644
--- a/games/mrboom/mrboom.SlackBuild
+++ b/games/mrboom/mrboom.SlackBuild
@@ -22,6 +22,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org:
+# - fix build on 15.0.
+# - actually use SLKCFLAGS.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mrboom
@@ -41,9 +45,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -78,11 +79,13 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
patch -p0 < $CWD/Makefile.patch
+sed -i "s,-O3,$SLKCFLAGS -fcommon," Makefile
+
sed -i "s|^GIT_VERSION :=.*|GIT_VERSION := \" ${VERSION}\"|" Makefile
if pkg-config --exists sdl2; then