summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2017-01-26 21:47:43 +0100
committer Willy Sudiarto Raharjo2017-02-04 01:00:04 +0100
commit31ffcff300758edcc3486d0432be760bb8978e70 (patch)
tree95f2935a2469a9b69d7719b4e1ea804b72e2f2e9 /games
parent1b452b611e92199d0db099be5bdb03aab009e8d7 (diff)
downloadslackbuilds-31ffcff300758edcc3486d0432be760bb8978e70.tar.gz
games/vbam: Updated for version 2.0.0beta3.
Diffstat (limited to 'games')
-rw-r--r--games/vbam/README26
-rw-r--r--games/vbam/vbam.SlackBuild54
-rw-r--r--games/vbam/vbam.info8
3 files changed, 58 insertions, 30 deletions
diff --git a/games/vbam/README b/games/vbam/README
index a30d9dd81a..a93e2e3a8c 100644
--- a/games/vbam/README
+++ b/games/vbam/README
@@ -1,18 +1,14 @@
-VisualBoyAdvance-M is a Nintendo Game Boy Emulator with high compatibility with
-commercial games.
+VisualBoyAdvance-M is a Nintendo Game Boy Emulator with high compatibility
+with commercial games. It emulates the Nintendo Game Boy Advance hand
+held console, in addition to the original Game Boy hand held systems
+and its Super and Color variants. VBA-M is a continued development of
+the now inactive VisualBoy Advance project, with many improvements from
+various developments of VBA.
-It emulates the Nintendo Game Boy Advance hand held console, in addition to the
-original Game Boy hand held systems and its Super and Color variants.
+This application is the wxGTK GUI version of VisualBoyAdvance-M. The
+name of the executable is "visualboyadvance-m".
-VBA-M is a continued development of the now inactive VisualBoy Advance project,
-with many improvements from various developments of VBA.
+FFMPEG=ON will enable recording and playback. It requires ffmpeg.
-This application is the wxGTK GUI version of VisualBoyAdvance-M. The name of the
-executable is "wxvbam".
-
-FFMPEG=ON will enable recording and playback. It requires FFMPEG.
-
-There are a couple of alternatives you might try instead of this VBAM
-SlackBuild.
-
-The first is mGBA, which is available on SlackBuilds.org.
+There are a couple of alternatives on SBo you might try instead of this
+VBAM SlackBuild: vbam-libretro, mgba, and/or libretro-mgba.
diff --git a/games/vbam/vbam.SlackBuild b/games/vbam/vbam.SlackBuild
index dc91a31b42..a03e5154c6 100644
--- a/games/vbam/vbam.SlackBuild
+++ b/games/vbam/vbam.SlackBuild
@@ -1,9 +1,11 @@
#!/bin/sh
# Slackbuild for vbam
-# Currently maintained by Dugan Chen <thedoogster@gmail.com>
+# Currently maintained by B. Watson <yalhcru@gmail.com>
-# Written by JK Wood <joshuakwood@gmail.com>
+# Previously maintained by Dugan Chen <email removed>
+
+# Written by JK Wood <email removed>
# Slackbuild is released under the Dog-on-Fire License:
# If use of this script causes your dog to catch on fire,
@@ -21,11 +23,29 @@
# Modified by the SlackBuilds.org project.
+# 20170126 bkw:
+# - New maintainer, remove old maintainers' email addresses.
+# - Update for 2.0.0beta3. This adds SDL2 and SFML as deps.
+# Actually I could make SFML optional, it's only used for emulating
+# the GBA link cable. If anyone *really* wants to do this, add
+# -DENABLE_LINK=OFF to the cmake command. Not going to add it as
+# an option unless someone requests it.
+# - Install binary in /usr/games, not /usr/bin.
+# - Use correct wx-config, even if /usr/bin/wx-config symlink points
+# to 2.8 instead of 3.0.
+# - Get rid of Windows-only doc.
+# - Binary & source name has changed to visualboyadvance-m, keep the
+# old vbam name as symlinks.
+# - Correct README, plus cosmetic reformatting.
+
PRGNAM=vbam
-VERSION=${VERSION:-r1507}
+VERSION=${VERSION:-2.0.0beta3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCVER="Beta-3"
+SRCNAM="visualboyadvance-m"
+
# Set to ON to enable FFMPEG A/V recording.
FFMPEG=${FFMPEG:-OFF}
@@ -65,9 +85,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz || tar xvf $CWD/$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -75,9 +95,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# if both wx(Python|GTK) 2 and 3 are installed, /usr/bin/wx-config
+# is a symlink to the config for whichever was installed last. Avoid
+# confusion, force the correct version.
+WXCONF=${WXCONF:-/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0}
+
+# install binary to /usr/games, since it's got a section 6 man page.
+sed -i '/DESTINATION bin/s,bin,games,' CMakeLists.txt
+
+# man pages go in Slack standard location.
+sed -i 's,share/man,man,g' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
+ -DwxWidgets_CONFIG_EXECUTABLE=$WXCONF \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -89,14 +121,14 @@ cd build
make install DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+strip $PKG/usr/games/$SRCNAM
+ln -s $SRCNAM $PKG/usr/games/$PRGNAM
-mv $PKG/usr/share/man $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip $PKG/usr/man/man6/$SRCNAM.6
+ln -s $SRCNAM.6.gz $PKG/usr/man/man6/$PRGNAM.6.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f doc/ReadMe.MFC.txt # this is for Windows only
cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/games/vbam/vbam.info b/games/vbam/vbam.info
index 7e3bfcb8dd..40c55ea842 100644
--- a/games/vbam/vbam.info
+++ b/games/vbam/vbam.info
@@ -1,10 +1,10 @@
PRGNAM="vbam"
-VERSION="r1507"
+VERSION="2.0.0beta3"
HOMEPAGE="http://vba-m.com/"
-DOWNLOAD="http://ks392457.kimsufi.com/orbea/stuff/slackbuilds/src/vbam-r1507.tar.xz"
-MD5SUM="c7be66a3224eaabb98548dc887ba7e0f"
+DOWNLOAD="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/Beta-3.tar.gz"
+MD5SUM="0b722fb702a34015dc4b37b57679ad20"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="OpenAL wxGTK3"
+REQUIRES="SDL2 SFML wxGTK3"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"