summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson2014-05-09 09:26:28 +0200
committer Willy Sudiarto Raharjo2014-05-12 02:36:01 +0200
commit327a851e33ad34eef2c43cbb23c88ad9bcff13f5 (patch)
tree0eb9bb239aaded72fb8c7ec88a1af3175e27900f /games
parent5357621b0214f91c87af107dd143464b83389db1 (diff)
downloadslackbuilds-327a851e33ad34eef2c43cbb23c88ad9bcff13f5.tar.gz
games/stratagus: Added (RTS game engine).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/stratagus/README12
-rw-r--r--games/stratagus/slack-desc19
-rw-r--r--games/stratagus/stratagus.SlackBuild106
-rw-r--r--games/stratagus/stratagus.info10
4 files changed, 147 insertions, 0 deletions
diff --git a/games/stratagus/README b/games/stratagus/README
new file mode 100644
index 0000000000..7aa94ec7ad
--- /dev/null
+++ b/games/stratagus/README
@@ -0,0 +1,12 @@
+stratagus (RTS game engine)
+
+Stratagus Core is a free cross-platform real-time strategy gaming
+engine. It includes support for playing over the internet/LAN, or playing
+a computer opponent. The engine is configurable and can be used to create
+games with a wide-range of features specific to your needs.
+
+If you're installing stratagus as a dependency for wargus, make sure the
+stratagus and wargus version numbers match. This shouldn't be a problem
+(both will be updated at SBo at the same time, when needed).
+
+Stratagus was formerly known as FreeCraft and ALE Clone.
diff --git a/games/stratagus/slack-desc b/games/stratagus/slack-desc
new file mode 100644
index 0000000000..8f1f45c139
--- /dev/null
+++ b/games/stratagus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+stratagus: stratagus (RTS game engine)
+stratagus:
+stratagus: Stratagus Core is a free cross-platform real-time strategy gaming
+stratagus: engine. It includes support for playing over the internet/LAN,
+stratagus: or playing a computer opponent. The engine is configurable and can
+stratagus: be used to create games with a wide-range of features specific to
+stratagus: your needs.
+stratagus:
+stratagus:
+stratagus:
+stratagus:
diff --git a/games/stratagus/stratagus.SlackBuild b/games/stratagus/stratagus.SlackBuild
new file mode 100644
index 0000000000..cff95dbb83
--- /dev/null
+++ b/games/stratagus/stratagus.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for stratagus
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# Note to future maintainers (in case I get hit by a bus or something):
+# If you update this, you need to update wargus to the same version. If
+# you see a newer stratagus release but wargus hasn't yet been updated,
+# resist the temptation to update to the new stratagus until the wargus
+# devs have made a release with the same version number. Failure to do
+# this will cause breakage...
+
+# Build option notes:
+# - technically libmikmod is optional, but it's a small lib with no deps
+# of its own. Games might need it, better to make it a hard dep.
+# - upx is disabled, it's only used for packing the stratagus executable,
+# which we don't do in SlackBuilds.
+# - touchscreen support is disabled. I have no hardware to test it on,
+# and generally Slackware isn't used on touchscreen devices. If you
+# want to play with it, add -DENABLE_TOUCHSCREEN=ON in the cmake
+# command below.
+
+PRGNAM=stratagus
+VERSION=${VERSION:-2.2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM}_${VERSION}.orig
+tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
+cd ${PRGNAM}_${VERSION}.orig
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# -DDOCDIR isn't 100% respected, some of the docs end up in hardcoded
+# share/doc/$PRGNAM, so:
+sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DENABLE_DOC=ON \
+ -DENABLE_DEV=ON \
+ -DENABLE_STRIP=ON \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMANDIR:PATH=man/man6 \
+ -DDOCDIR:PATH=doc/$PRGNAM-$VERSION \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+# get rid of empty useless file
+rm -f $PKG/usr/include/*.nsi
+
+gzip -9 $PKG/usr/man/man6/$PRGNAM.6
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/stratagus/stratagus.info b/games/stratagus/stratagus.info
new file mode 100644
index 0000000000..656f5b55db
--- /dev/null
+++ b/games/stratagus/stratagus.info
@@ -0,0 +1,10 @@
+PRGNAM="stratagus"
+VERSION="2.2.7"
+HOMEPAGE="http://stratagus.com/"
+DOWNLOAD="https://launchpad.net/stratagus/trunk/2.2.7/+download/stratagus_2.2.7.orig.tar.gz"
+MD5SUM="48181bf0234d0a2ee4b0e08ae1841477"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="tolua++ libmikmod"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"