summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author LEVAI Daniel2013-06-18 20:49:55 +0200
committer Niels Horn2013-06-23 02:32:52 +0200
commitdd0687b1c8f5b004f10b70b052ff7fbc6de1fa11 (patch)
tree46376e440586157cc4b756060274bc56b62c5f6b /games
parent466d423c7c56037e6177c1aee97bd426bf0ab071 (diff)
downloadslackbuilds-dd0687b1c8f5b004f10b70b052ff7fbc6de1fa11.tar.gz
games/garden: Added (2D vertical shoot-em-up game)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/garden/README8
-rw-r--r--games/garden/doinst.sh9
-rw-r--r--games/garden/garden.SlackBuild95
-rw-r--r--games/garden/garden.info10
-rw-r--r--games/garden/slack-desc19
5 files changed, 141 insertions, 0 deletions
diff --git a/games/garden/README b/games/garden/README
new file mode 100644
index 0000000000..d750883c56
--- /dev/null
+++ b/games/garden/README
@@ -0,0 +1,8 @@
+Garden of coloured lights is an old school 2D vertical shoot-em-up with some
+innovative elements. Innovative graphics, soundtrack and game concept. The game
+itself is very challenging and as you progress, you will understand that you
+are dealing with a true piece of art...
+
+It is not an easy game, so you will need some skill and patience... And maybe
+you will appreciate the possibility to use a joystick. And yes, it is actually
+possible to get to stage 4 :-)
diff --git a/games/garden/doinst.sh b/games/garden/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/games/garden/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/garden/garden.SlackBuild b/games/garden/garden.SlackBuild
new file mode 100644
index 0000000000..d4843eb938
--- /dev/null
+++ b/games/garden/garden.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Copyright (c) 2013 LEVAI Daniel
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# * Neither the name of the <organization> nor the
+# names of its contributors may be used to endorse or promote products
+# derived from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=garden
+VERSION=1.0.8
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "${ARCH}" == "i486" ];then
+ SLKCFLAGS='-march=i486 -mtune=i686'
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" == "i686" ]; then
+ SLKCFLAGS="-march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "${ARCH}" == "x86_64" ];then
+ SLKCFLAGS='-fPIC'
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -Rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -Rf $PRGNAM
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+./configure \
+ --prefix=/usr
+
+# link to libm (symbol `hypot@@GLIBC_2.0' is missing otherwise)
+sed -r -i -e 's/^(LDFLAGS =)/\1 -lm/' bin/Makefile
+
+make
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog INSTALL NEWS COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/garden/garden.info b/games/garden/garden.info
new file mode 100644
index 0000000000..c79c5dc95d
--- /dev/null
+++ b/games/garden/garden.info
@@ -0,0 +1,10 @@
+PRGNAM="garden"
+VERSION="1.0.8"
+HOMEPAGE="http://garden.sourceforget.net"
+DOWNLOAD="http://downloads.sourceforge.net/garden/garden-1.0.8.tar.gz"
+MD5SUM="42966f2c457d71a3ff0dd30522801ade"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="allegro"
+MAINTAINER="LEVAI Daniel"
+EMAIL="leva@ecentrum.hu"
diff --git a/games/garden/slack-desc b/games/garden/slack-desc
new file mode 100644
index 0000000000..50a78c5f68
--- /dev/null
+++ b/games/garden/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+garden: garden (2D vertical shoot-em-up game)
+garden:
+garden: Garden of coloured lights is an old school 2D vertical shoot-em-up
+garden: with some innovative elements. Innovative graphics, soundtrack and
+garden: game concept. The game itself is very challenging and as you
+garden: progress, you will understand that you are dealing with a true piece
+garden: of art...
+garden:
+garden: Homepage: http://garden.sourceforge.net
+garden:
+garden: