summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Dugan Chen2012-01-11 15:55:38 +0100
committer Erik Hanson2012-01-11 15:55:38 +0100
commitb68700178f6e0077f96420b399af6e8c18200dbf (patch)
tree86739dd5891a919dd3e3e9a2b4537749c97bf21e /games
parent2238f23b7491651e4e484910af977a3446bcf80d (diff)
downloadslackbuilds-b68700178f6e0077f96420b399af6e8c18200dbf.tar.gz
games/nethack: Added (roguelike game)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/nethack/README6
-rw-r--r--games/nethack/nethack.SlackBuild112
-rw-r--r--games/nethack/nethack.info10
-rw-r--r--games/nethack/slack-desc19
4 files changed, 147 insertions, 0 deletions
diff --git a/games/nethack/README b/games/nethack/README
new file mode 100644
index 0000000000..5a26958455
--- /dev/null
+++ b/games/nethack/README
@@ -0,0 +1,6 @@
+Nethack is a single-player dungeon exploration game. The emphasis is
+on discovering the detail of the dungeon. Each game presents a
+different landscape - the random number generator provides an
+essentially unlimited number of variations of the dungeon and its
+denizens to be discovered by the player in one of a number of
+characters: you can pick your race, your role, and your gender.
diff --git a/games/nethack/nethack.SlackBuild b/games/nethack/nethack.SlackBuild
new file mode 100644
index 0000000000..5667226fbd
--- /dev/null
+++ b/games/nethack/nethack.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for nethack.
+
+# Written by Dugan Chen (thedoogster@gmail.com)
+
+PRGNAM=nethack
+VERSION=${VERSION:-3.4.3}
+SRCVER=${SRCVER:-343}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$SRCVER-src.tgz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sh sys/unix/setup.sh
+
+sed -e '/define HACKDIR/ s|/usr/games/lib/nethackdir|/var/games/nethack/|' \
+ -e '/^#define COMPRESS\s/ s|/usr/bin/compress|/bin/gzip|' \
+ -e '/^#define COMPRESS_EXTENSION/ s|".Z"|".gz"|' \
+ -e 's|^/\* \(#define DLB\) \*/|\1|' -i include/config.h
+
+sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
+ -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|' -i include/unixconf.h
+
+sed -e 's|^# \(WINTTYLIB = -lncurses\)|\1|' \
+ -e 's|^WINTTYLIB = -ltermlib|#&|' -i src/Makefile
+
+# we are setting up for setgid games, so modify all necessary permissions
+# to allow full access for groups
+
+sed -e '/^GAMEDIR\s*=/ s|/games/.*$|/var/games/$(GAME)|' \
+ -e '/^GAMEUID\s*=/ s|games|root|' \
+ -e '/^GAMEGRP\s*=/ s|bin|games|' \
+ -e '/^GAMEPERM\s*=/ s|04755|02755|' \
+ -e '/^FILEPERM\s*=/ s|0644|0664|' \
+ -e '/^DIRPERM\s*=/ s|0755|0775|' \
+ -e '/^SHELLDIR\s*=/ s|/games|/usr/bin|' -i Makefile
+
+sed -e "/^MANDIR\s*=/s|/usr/man/man6|$PKG/usr/man/man6|" -i doc/Makefile
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+install -dm755 $PKG/usr/man/man6
+install -dm775 $PKG/var/games/
+make PREFIX=$PKG install manpages
+sed -e "s|HACKDIR=$PKG/|HACKDIR=/|" \
+ -e 's|HACK=$HACKDIR|HACK=/usr/lib/nethack|' \
+ -i $PKG/usr/bin/nethack
+
+install -dm755 $PKG/usr/lib/nethack
+mv $PKG/var/games/nethack/{nethack,recover} $PKG/usr/lib/nethack/
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ doc/Guidebook.txt dat/license \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/nethack/nethack.info b/games/nethack/nethack.info
new file mode 100644
index 0000000000..00c0249d19
--- /dev/null
+++ b/games/nethack/nethack.info
@@ -0,0 +1,10 @@
+PRGNAM="nethack"
+VERSION="3.4.3"
+HOMEPAGE="http://nethack.org"
+DOWNLOAD="http://downloads.sourceforge.net/project/nethack/nethack/3.4.3/nethack-343-src.tgz"
+MD5SUM="21479c95990eefe7650df582426457f9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Dugan Chen"
+EMAIL="thedoogster@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/games/nethack/slack-desc b/games/nethack/slack-desc
new file mode 100644
index 0000000000..e3e92242d9
--- /dev/null
+++ b/games/nethack/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nethack: nethack (roguelike game)
+nethack:
+nethack: Nethack is a single-player dungeon exploration game. The emphasis is
+nethack: on discovering the detail of the dungeon. Each game presents a
+nethack: different landscape - the random number generator provides an
+nethack: essentially unlimited number of variations of the dungeon and its
+nethack: denizens to be discovered by the player in one of a number of
+nethack: characters: you can pick your race, your role, and your gender.
+nethack:
+nethack: http://nethack.org
+nethack: