summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Zbigniew Baniewski2013-06-30 07:25:46 +0200
committer Erik Hanson2013-06-30 07:25:46 +0200
commit9e74f87699287cdc59f01cdb565a68521365e1bc (patch)
tree1f193ab9cc0831056631a08c0aecc1358cac6a4e /games
parent918a1e3ff8516fcb6b6dbb03dde3b45f28112440 (diff)
downloadslackbuilds-9e74f87699287cdc59f01cdb565a68521365e1bc.tar.gz
games/f1spirit: Added (F-1 Spirit Remake)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/f1spirit/01-no-curl-types.patch11
-rw-r--r--games/f1spirit/02-Makefile.patch12
-rw-r--r--games/f1spirit/README9
-rw-r--r--games/f1spirit/doinst.sh9
-rw-r--r--games/f1spirit/f1spirit.SlackBuild70
-rw-r--r--games/f1spirit/f1spirit.info10
-rw-r--r--games/f1spirit/slack-desc19
7 files changed, 140 insertions, 0 deletions
diff --git a/games/f1spirit/01-no-curl-types.patch b/games/f1spirit/01-no-curl-types.patch
new file mode 100644
index 0000000000..8f4b73897b
--- /dev/null
+++ b/games/f1spirit/01-no-curl-types.patch
@@ -0,0 +1,11 @@
+diff -Nur f1spirit-0.rc9.1615/sources/F1Shttp.cpp f1spirit-0.rc9.1615.new/sources/F1Shttp.cpp
+--- f1spirit-0.rc9.1615/sources/F1Shttp.cpp 2009-02-06 09:54:49.000000000 +0000
++++ f1spirit-0.rc9.1615.new/sources/F1Shttp.cpp 2013-06-12 16:24:55.423054962 +0000
+@@ -3,7 +3,6 @@
+ #include "string.h"
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ #include "F1Shttp.h"
diff --git a/games/f1spirit/02-Makefile.patch b/games/f1spirit/02-Makefile.patch
new file mode 100644
index 0000000000..9b2d8810f3
--- /dev/null
+++ b/games/f1spirit/02-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Nur f1spirit-0.rc9.1615/build/linux/Makefile f1spirit-0.rc9.1615.new/build/linux/Makefile
+--- f1spirit-0.rc9.1615/build/linux/Makefile 2009-02-06 10:12:51.000000000 +0000
++++ f1spirit-0.rc9.1615.new/build/linux/Makefile 2013-06-12 18:21:52.435681841 +0000
+@@ -41,7 +41,7 @@
+ CC = gcc
+ #CFLAGS = -g3 -O3 -Wall `sdl-config --cflags` `curl-config --cflags` -I/usr/X11R6/include
+ CFLAGS = -g3 -O3 -Wno-write-strings `sdl-config --cflags` `curl-config --cflags` -I/usr/X11R6/include
+-LDFLAGS = `sdl-config --libs` `curl-config --libs` -L/usr/X11R6/lib/ -lSDL_image -lSDL_mixer -lSDL_net -lGL -lGLU
++LDFLAGS = `sdl-config --libs` `curl-config --libs` -L/usr/X11R6/lib/ -lSDL_image -lSDL_mixer -lSDL_net -lGL -lGLU -lm -lstdc++
+ RM = rm -f
+ CP = cp -r
+ MD = mkdir -p
diff --git a/games/f1spirit/README b/games/f1spirit/README
new file mode 100644
index 0000000000..d93915f51b
--- /dev/null
+++ b/games/f1spirit/README
@@ -0,0 +1,9 @@
+This game was developed for the RETRO-REMAKES REMAKE COMPETITION 2004
+organized by http://www.remakes.org
+
+This is the unofficial remake of Konami's F-1 SPIRIT which was originally
+released in 1987 for the MSX home computer systems.
+
+The game starts in windowed mode, switch to fullscreen by pressing ALT+ENTER
+
+To quit the game at ANY moment, press F12
diff --git a/games/f1spirit/doinst.sh b/games/f1spirit/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/games/f1spirit/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/f1spirit/f1spirit.SlackBuild b/games/f1spirit/f1spirit.SlackBuild
new file mode 100644
index 0000000000..cedeead1ad
--- /dev/null
+++ b/games/f1spirit/f1spirit.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for f1spirit
+
+# Written by Zbigniew Baniewski, Zbigniew.Baniewski@gmail.com
+
+PRGNAM=f1spirit
+VERSION=0.rc9.1615
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM}-$VERSION __MACOSX
+unzip $CWD/${PRGNAM}-${VERSION}.zip
+cat $CWD/01-no-curl-types.patch | patch -p0 || exit
+cat $CWD/02-Makefile.patch | patch -p0 || exit
+cd ${PRGNAM}-${VERSION}
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+make install PREFIX=$PKG/usr
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/f1spirit/f1spirit.info b/games/f1spirit/f1spirit.info
new file mode 100644
index 0000000000..952c300419
--- /dev/null
+++ b/games/f1spirit/f1spirit.info
@@ -0,0 +1,10 @@
+PRGNAM="f1spirit"
+VERSION="0.rc9.1615"
+HOMEPAGE="http://www.braingames.getput.com/"
+DOWNLOAD="https://www.cs.drexel.edu/~santi/games/f1spirit-0.rc9.1615.zip"
+MD5SUM="4ecc4d0fccc706ea2eeebc433ce177df"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Zbigniew Baniewski"
+EMAIL="Zbigniew.Baniewski@gmail.com"
diff --git a/games/f1spirit/slack-desc b/games/f1spirit/slack-desc
new file mode 100644
index 0000000000..79978734e3
--- /dev/null
+++ b/games/f1spirit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+f1spirit: f1spirit (F-1 Spirit Remake)
+f1spirit:
+f1spirit: F-1 Spirit is a racing game. You will race with many different types
+f1spirit: of cars, starting by Stock or Rally cars, and finishing by driving
+f1spirit: F1 cars (once you have classified for it by passing for F3, F3000
+f1spirit: and Endurance cars).
+f1spirit:
+f1spirit: Homepage: http://www.braingames.getput.com/
+f1spirit:
+f1spirit:
+f1spirit: