summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Matteo Bernardini2012-09-16 12:02:33 +0200
committer dsomero2012-09-17 01:44:42 +0200
commitbc667d563855e5f521ae41074bc8497a0769f9a4 (patch)
treeee56bcacd5c312d590cee279e76252894c511d49 /games
parent83822794e5980fc7d6df13fa44bc0a15e4ff2cec (diff)
downloadslackbuilds-bc667d563855e5f521ae41074bc8497a0769f9a4.tar.gz
games/clonekeen: Fixed underlinking.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/clonekeen/clonekeen.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/clonekeen/clonekeen.SlackBuild b/games/clonekeen/clonekeen.SlackBuild
index ac178a730b..b41aa20638 100644
--- a/games/clonekeen/clonekeen.SlackBuild
+++ b/games/clonekeen/clonekeen.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=clonekeen
VERSION=${VERSION:-8.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -49,6 +49,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix underlinking
+sed -i "s|-lstdc++|-lstdc++ -lm|" src/Makefile
+
# Makefile doesn't use CFLAGS, ugh
sed -i "/gcc/s/-O2/$SLKCFLAGS/" src/Makefile