summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali2011-09-06 04:53:33 +0200
committer Robby Workman2011-09-06 04:53:33 +0200
commit32a3f978c6623706ae5609ae8cc9a35d0f3ca7f1 (patch)
tree3fd8ec3aa2ceca81fef8cf9e6756f06567a9a1e2 /games
parent88f2c5e70adc4d9ec141e94989e808bb93dfe7ea (diff)
downloadslackbuilds-32a3f978c6623706ae5609ae8cc9a35d0f3ca7f1.tar.gz
games/bsnes: Updated for version 0.082.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/bsnes/bsnes-0.076-toolkit.patch23
-rw-r--r--games/bsnes/bsnes.SlackBuild31
-rw-r--r--games/bsnes/bsnes.info8
3 files changed, 14 insertions, 48 deletions
diff --git a/games/bsnes/bsnes-0.076-toolkit.patch b/games/bsnes/bsnes-0.076-toolkit.patch
deleted file mode 100644
index 079a864dd0..0000000000
--- a/games/bsnes/bsnes-0.076-toolkit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/bsnes/ui/Makefile b/bsnes/ui/Makefile
-index d5f72eb..604a0f7 100755
---- a/bsnes/ui/Makefile
-+++ b/bsnes/ui/Makefile
-@@ -7,11 +7,13 @@ ui_objects += $(if $(call streq,$(platform),win),resource)
-
- # platform
- ifeq ($(platform),x)
--# phoenix_compile = $(call compile,-DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`)
--# link += `pkg-config --libs gtk+-2.0`
--
-- phoenix_compile = $(call compile,-DPHOENIX_QT `pkg-config --cflags QtCore QtGui`)
-- link += `pkg-config --libs QtCore QtGui`
-+ ifeq ($(toolkit),gtk)
-+ phoenix_compile = $(call compile,-DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`)
-+ link += `pkg-config --libs gtk+-2.0`
-+ else ifeq ($(toolkit),qt)
-+ phoenix_compile = $(call compile,-DPHOENIX_QT `pkg-config --cflags QtCore QtGui`)
-+ link += `pkg-config --libs QtCore QtGui`
-+ endif
-
- ruby := video.glx video.xv video.sdl
- ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index 3c5bc2d16d..22a62f5306 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=bsnes
-VERSION=${VERSION:-0.080}
+VERSION=${VERSION:-0.082}
SRCVER=${VERSION:2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,14 +53,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch makefile so SLKCFLAGS are recognized and give option to choose
-# Qt4 or Gtk interface.
-patch -p1 < $CWD/bsnes-0.076-toolkit.patch
+# Patch makefile so SLKCFLAGS are recognized.
patch -p1 < $CWD/bsnes-0.077-makefile.patch
-# Fix snespurify scripts.
-sed -i 's|g++-4.5|g++|g' snespurify/cc-{gtk,qt}.sh
-
cd $PRGNAM
# Remove pulseaudio as there is no package for it at SBo.
@@ -71,15 +66,14 @@ sed -i \
-e '/pulse/d' ui{,-gameboy}/Makefile
# Choose whether qt or gtk interface is used. Qt4 is default.
-INTERFACE=${INTERFACE:-QT4}
-if ! [ "$INTERFACE" == 'QT4' ]; then
- TOOLKIT='gtk'
+if [ "${INTERFACE:-QT4}" != 'QT4' ]; then
+ PHOENIX='gtk'
else
- TOOLKIT='qt'
+ PHOENIX='qt'
fi
# Determine which mode to build bsnes.
-# Possible values for PROFILE are accuracy, compatibility, and performance.
+# Possible values for PROFILE: accuracy, compatibility, and performance.
PROFILE=${PROFILE:-compatibility}
CXXFLAGS="$SLKCFLAGS" \
@@ -87,7 +81,7 @@ make \
platform=x \
compiler=gcc \
prefix=/usr \
- toolkit="$TOOLKIT" \
+ phoenix="$PHOENIX" \
profile="$PROFILE"
make install DESTDIR=$PKG prefix=/usr
@@ -96,14 +90,9 @@ cd ..
# Compile snespurify. It helps clean up ROMS for use with bsnes.
cd snespurify
# Fix snespurify scripts.
-sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-{gtk,qt}.sh
-if [ "$INTERFACE" == "QT4" ]; then
- ./cc-qt.sh
- install -m 0755 snespurify-qt $PKG/usr/bin
-else
- ./cc-gtk.sh
- install -m 0755 snespurify-gtk $PKG/usr/bin
-fi
+sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-${PHOENIX}.sh
+./cc-${PHOENIX}.sh
+install -m 0755 snespurify-$PHOENIX $PKG/usr/bin
cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/games/bsnes/bsnes.info b/games/bsnes/bsnes.info
index 142a202a11..56d78889d1 100644
--- a/games/bsnes/bsnes.info
+++ b/games/bsnes/bsnes.info
@@ -1,10 +1,10 @@
PRGNAM="bsnes"
-VERSION="0.080"
+VERSION="0.082"
HOMEPAGE="http://byuu.org/bsnes/"
-DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v080-source.tar.bz2"
-MD5SUM="a5697cc0a15cb22e628eea2c74396e88"
+DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v082-source.tar.bz2"
+MD5SUM="c7deead3fb28bcf1aa7bcef44f236f59"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman,Niels Horn"
+APPROVED="rworkman"