summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali2010-08-26 02:47:23 +0200
committer Erik Hanson2010-08-29 22:32:12 +0200
commiteaf7f4d9be4a34e87b1b06f821a64f345098ea2e (patch)
tree17236d86c982a207b378c935f4350a8f5ca29e1c /games
parent5875a1eacd7c5d2fa6c835a554bf6a52195cde72 (diff)
downloadslackbuilds-eaf7f4d9be4a34e87b1b06f821a64f345098ea2e.tar.gz
games/bsnes: Updated for version 0.068.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/bsnes/bsnes-0.068-makefile.patch (renamed from games/bsnes/bsnes-0.064-makefile.patch)17
-rw-r--r--games/bsnes/bsnes.SlackBuild11
-rw-r--r--games/bsnes/bsnes.info8
-rw-r--r--games/bsnes/slack-desc4
4 files changed, 21 insertions, 19 deletions
diff --git a/games/bsnes/bsnes-0.064-makefile.patch b/games/bsnes/bsnes-0.068-makefile.patch
index 754dfe23dd..18399a7546 100644
--- a/games/bsnes/bsnes-0.064-makefile.patch
+++ b/games/bsnes/bsnes-0.068-makefile.patch
@@ -63,12 +63,12 @@ diff --git a/src/Makefile b/src/Makefile
index c3c1fe9..4b5de6d 100755
--- a/Makefile
+++ b/Makefile
-@@ -4,7 +4,7 @@ ui := ui_qt
+@@ -4,7 +4,7 @@ ui := qt
# compiler
c := $(compiler) -std=gnu99
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
--flags := -O3 -fomit-frame-pointer -I.
-+flags := $(CXXFLAGS) -fomit-frame-pointer -I.
+-flags := -O3 -fomit-frame-pointer -I. -I$(snes)
++flags := $(CXXFLAGS) -fomit-frame-pointer -I. -I$(snes)
link :=
objects :=
@@ -84,11 +84,12 @@ index c3c1fe9..4b5de6d 100755
@@ -60,8 +60,8 @@ endif
install:
ifeq ($(platform),x)
- install -D -m 755 ../bsnes $(DESTDIR)$(prefix)/bin/bsnes
-- install -D -m 644 data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
-- install -D -m 644 data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
-+ install -D -m 644 data/bsnes.png $(DESTDIR)/usr/share/pixmaps/bsnes.png
-+ install -D -m 644 data/bsnes.desktop $(DESTDIR)/usr/share/applications/bsnes.desktop
+- install -D -m 755 out/bsnes-$(profile) $(DESTDIR)$(prefix)/bin/bsnes-$(profile)
+- install -D -m 644 qt/data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
+- install -D -m 644 qt/data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
++ install -D -m 755 out/bsnes-$(profile) $(DESTDIR)$(prefix)/bin/bsnes
++ install -D -m 644 qt/data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
++ install -D -m 644 qt/data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
endif
uninstall:
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index 69fc13d99c..db126d5e86 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=bsnes
-VERSION=${VERSION:-0.067}
+VERSION=${VERSION:-0.068}
SRCVER=${VERSION:2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,6 +46,7 @@ rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_v${SRCVER}.tar.bz2
+find . -type d -exec chmod -R 0755 {} \;
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -53,10 +54,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-cd src
+cd $PRGNAM
# Patch makefile so SLKCFLAGS and LIBDIRSUFFIX are recognized.
-cat $CWD/bsnes-0.064-makefile.patch \
+cat $CWD/bsnes-0.068-makefile.patch \
| sed -e "/^\+/s|/lib/|/lib${LIBDIRSUFFIX}/|g" \
| patch -p1
@@ -65,7 +66,7 @@ cat $CWD/bsnes-0.064-makefile.patch \
sed -i \
-e 's|audio.pulseaudio ||' \
-e 's|audio.pulseaudiosimple ||' \
- -e '/pulse/d' ui_qt/Makefile
+ -e '/pulse/d' qt/Makefile
CXXFLAGS="$SLKCFLAGS" \
make \
@@ -92,7 +93,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
diff --git a/games/bsnes/bsnes.info b/games/bsnes/bsnes.info
index 2be94825dd..ce29e2e091 100644
--- a/games/bsnes/bsnes.info
+++ b/games/bsnes/bsnes.info
@@ -1,10 +1,10 @@
PRGNAM="bsnes"
-VERSION="0.067"
+VERSION="0.068"
HOMEPAGE="http://byuu.org/bsnes/"
-DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v067.tar.bz2"
-MD5SUM="c0cc823fe0b15a892af9e6d864214e29"
+DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v068.tar.bz2"
+MD5SUM="9ff2f6dc64f54f0da538cefade64b3a7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="Erik Hanson"
+APPROVED="dsomero"
diff --git a/games/bsnes/slack-desc b/games/bsnes/slack-desc
index de8921d17b..93af4388c3 100644
--- a/games/bsnes/slack-desc
+++ b/games/bsnes/slack-desc
@@ -7,13 +7,13 @@
|-----handy-ruler------------------------------------------------------|
bsnes: bsnes (SNES Emulator)
-bsnes:
+bsnes:
bsnes: bsnes is an emulator that began development on 2004-10-14. The purpose
bsnes: of this emulator is a bit different from others: it focuses on
bsnes: accuracy, debugging functionality, and clean code. The emulator does
bsnes: not focus on things that would hinder accuracy. This includes speed
bsnes: and game-specific hacks for compatibility. As a result, the minimum
bsnes: system requirements for bsnes are very high.
-bsnes:
+bsnes:
bsnes: Homepage: http://byuu.org/bsnes/
bsnes: