summaryrefslogtreecommitdiffstats
path: root/games/pysolfc/pysolfc.SlackBuild
diff options
context:
space:
mode:
author Matthew Fillpot2010-07-03 06:29:45 +0200
committer Erik Hanson2010-07-03 06:29:45 +0200
commitbc032a906a7b83a09465cf27343a3d354d96d863 (patch)
tree5b45d8f9a19d41c1cb965f08b88db607223c9791 /games/pysolfc/pysolfc.SlackBuild
parent85fb475c0e31722cd7e11732bf39ea90218b8416 (diff)
downloadslackbuilds-bc032a906a7b83a09465cf27343a3d354d96d863.tar.gz
games/pysolfc: Updated for version 2.0.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'games/pysolfc/pysolfc.SlackBuild')
-rw-r--r--games/pysolfc/pysolfc.SlackBuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/games/pysolfc/pysolfc.SlackBuild b/games/pysolfc/pysolfc.SlackBuild
index 83c3e7981a..99fcfd6556 100644
--- a/games/pysolfc/pysolfc.SlackBuild
+++ b/games/pysolfc/pysolfc.SlackBuild
@@ -24,18 +24,16 @@
PRGNAM=PySolFC
PKGNAM=pysolfc
-VERSION=${VERSION:-1.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CARDSETS=$PRGNAM-Cardsets-$VERSION
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -60,18 +58,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-## Upstream left a file out of the tarball:
-## http://sourceforge.net/forum/forum.php?thread_id=1847958&forum_id=503709
-cp $CWD/pysolfc.glade data
-
python setup.py install --root $PKG
mkdir -p $PKG/usr/man/man6
cat docs/pysol.6 > $PKG/usr/man/man6/pysol.6 ; gzip $PKG/usr/man/man6/pysol.6
-mkdir -p $PKG/usr/share/applications
-cat $CWD/$PKGNAM.desktop > $PKG/usr/share/applications/$PKGNAM.desktop
-
## Are we installing extra cardsets?
if [ -e $CWD/$CARDSETS.tar.bz2 ]; then
echo -e "Extracting extra cardsets (this may take some time)..."
@@ -86,6 +77,7 @@ cat $CWD/$PKGNAM.SlackBuild > $PKG/usr/doc/$PKGNAM-$VERSION/$PKGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}