summaryrefslogtreecommitdiffstats
path: root/games/ggmud/ggmud-link.diff
diff options
context:
space:
mode:
author Eric Underhill2015-10-03 03:54:10 +0200
committer Willy Sudiarto Raharjo2015-10-03 03:54:10 +0200
commit4cd63afd3e2ca8d60ff182bb542d7ce28aca18d0 (patch)
tree959b06db6509c1474faf478a5a8403b8433b9ba5 /games/ggmud/ggmud-link.diff
parent508c3af024b7f4dc3fadf5432a28532f8602a73d (diff)
downloadslackbuilds-4cd63afd3e2ca8d60ff182bb542d7ce28aca18d0.tar.gz
games/ggmud: Added (console MUD client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/ggmud/ggmud-link.diff')
-rw-r--r--games/ggmud/ggmud-link.diff9
1 files changed, 9 insertions, 0 deletions
diff --git a/games/ggmud/ggmud-link.diff b/games/ggmud/ggmud-link.diff
new file mode 100644
index 0000000000..02eae42f89
--- /dev/null
+++ b/games/ggmud/ggmud-link.diff
@@ -0,0 +1,9 @@
+diff -rupN ./CMakeLists.txt ./CMakeLists.txt
+--- ./CMakeLists.txt 2015-09-26 02:34:29.547077049 -0700
++++ ./CMakeLists.txt 2015-09-25 22:58:00.000000000 -0700
+@@ -65,4 +65,4 @@ add_executable(ggmud WIN32 alias.c ansi.
+ ${ADDITIONAL_SOURCES}
+ )
+
+-target_link_libraries(ggmud tt lua sq3 httpfetch zlib ${GTK2_LIBRARIES} ${ADDITIONAL_LIBS} ${GTHREAD_LIBRARIES})
++target_link_libraries(ggmud tt lua sq3 httpfetch zlib dl m ${GTK2_LIBRARIES} ${ADDITIONAL_LIBS} ${GTHREAD_LIBRARIES})