summaryrefslogtreecommitdiffstats
path: root/games/BeastieWorker/Makefile.patch
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-04-22 02:37:13 +0200
committer Willy Sudiarto Raharjo2014-04-23 02:51:56 +0200
commit6de96aac5fe7da68f7b806c840848a40ab951b4b (patch)
tree4877f3b4813cf17f285bde57717e95df9da83717 /games/BeastieWorker/Makefile.patch
parentd7d1327dc1a3c5d88d6b4294cb27c419bb185af4 (diff)
downloadslackbuilds-6de96aac5fe7da68f7b806c840848a40ab951b4b.tar.gz
games/BeastieWorker: Added (3D sokoban-like game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/BeastieWorker/Makefile.patch')
-rw-r--r--games/BeastieWorker/Makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/games/BeastieWorker/Makefile.patch b/games/BeastieWorker/Makefile.patch
new file mode 100644
index 0000000000..56e2a0017f
--- /dev/null
+++ b/games/BeastieWorker/Makefile.patch
@@ -0,0 +1,13 @@
+--- BeastieWorker-0.4/src/Makefile.original 2014-04-21 12:16:55.317087746 +0300
++++ BeastieWorker-0.4/src/Makefile 2014-04-21 13:35:23.362229082 +0300
+@@ -3,8 +3,8 @@
+ DEL=rm
+
+ LFLAGS= -O2 -pthread
+-INCS= -I/usr/local/include/SDL11 -I/usr/X11R6/include/
+-LIBS= -L/usr/local/lib -lSDL-1.1 -L/usr/X11R6/lib -lGL -lGLU
++INCS= -I/usr/include/SDL -I/usr/X11R6/include/
++LIBS= -L/usr/lib -lSDL -L/usr/X11R6/lib -lGL -lGLU
+ OBJS= cursor.o font.o main.o matrixmath.o menu.o model3d.o player.o scene.o sound.o strings.o texture.o sky.o
+ MAIN= BeastieWorker
+