summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author David Stes2022-04-06 12:59:23 +0200
committer Willy Sudiarto Raharjo2022-04-09 10:45:49 +0200
commit904dc75d3e54b916f252598792a9332a72d61f5a (patch)
tree09fec31135a449f417163011a5b23c27ed28f2ac /development
parentee828df0135b223d04b690ad37ccc2dd1e364a63 (diff)
downloadslackbuilds-904dc75d3e54b916f252598792a9332a72d61f5a.tar.gz
development/squeak-vm: Added (squeak virtual machine).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/squeak-vm/README13
-rw-r--r--development/squeak-vm/slack-desc19
-rw-r--r--development/squeak-vm/squeak-vm.SlackBuild124
-rw-r--r--development/squeak-vm/squeak-vm.info10
4 files changed, 166 insertions, 0 deletions
diff --git a/development/squeak-vm/README b/development/squeak-vm/README
new file mode 100644
index 0000000000..7d4e717722
--- /dev/null
+++ b/development/squeak-vm/README
@@ -0,0 +1,13 @@
+Squeak is a full-featured implementation of the Smalltalk
+programming language and environment based on the original
+Smalltalk-80 system.
+
+Squeak has very powerful 2- and 3-D graphics, sound, video, MIDI,
+animation and other multimedia capabilities.
+
+Optional dependency: speex
+
+NOTE:
+This script only build the VM.
+You may need to download the images manually via download page:
+http://squeakvm.org/unix/download.html
diff --git a/development/squeak-vm/slack-desc b/development/squeak-vm/slack-desc
new file mode 100644
index 0000000000..5552600468
--- /dev/null
+++ b/development/squeak-vm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+squeak-vm: squeak-vm (squeak virtual machine)
+squeak-vm:
+squeak-vm: Squeak is a full-featured implementation of the Smalltalk
+squeak-vm: programming language and environment based on the original
+squeak-vm: Smalltalk-80 system.
+squeak-vm:
+squeak-vm: Squeak has very powerful 2- and 3-D graphics, sound, video, MIDI,
+squeak-vm: animation and other multimedia capabilities.
+squeak-vm:
+squeak-vm: Project Site: http://squeakvm.org/index.html
+squeak-vm:
diff --git a/development/squeak-vm/squeak-vm.SlackBuild b/development/squeak-vm/squeak-vm.SlackBuild
new file mode 100644
index 0000000000..0ca7482570
--- /dev/null
+++ b/development/squeak-vm/squeak-vm.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for squeak-vm
+
+# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+# Copyright 2022 David Stes <stes@telenet.be>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=squeak-vm
+SRCNAM=Squeak
+VERSION=${VERSION:-4.19.9.3816}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/Sbo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION-src
+tar xvf $CWD/$SRCNAM-$VERSION-src.tar.gz
+cd $SRCNAM-$VERSION-src
+cd platforms
+
+# Fix location of libraries (as --libdir does not work)
+for f in CMakeLists.txt cmake/squeak.in cmake/squeak.sh.in; do
+ sed \
+ -e "s/lib\/squeak/lib${LIBDIRSUFFIX}\/squeak/g" \
+ -i unix/$f
+done
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ../unix/cmake/configure \
+ --prefix=/usr \
+ --src=../../src \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-mpg-mmx \
+ --without-SUGAR \
+ --build=$ARCH-slackware-linux
+
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/man
+mv $PKG/usr/share/man/* $PKG/usr/man/
+rm -rf $PKG/usr/share/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ unix/ChangeLog unix/README* unix/doc/COPYING unix/doc/COPYRIGHT unix/doc/LICENSE \
+ unix/doc/README* unix/doc/HowTo* unix/doc/*RELEASE_NOTES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/squeak-vm/squeak-vm.info b/development/squeak-vm/squeak-vm.info
new file mode 100644
index 0000000000..7fb7a15e8a
--- /dev/null
+++ b/development/squeak-vm/squeak-vm.info
@@ -0,0 +1,10 @@
+PRGNAM="squeak-vm"
+VERSION="4.19.9.3816"
+HOMEPAGE="http://squeakvm.org/"
+DOWNLOAD="https://sourceforge.net/projects/solaris-squeak/files/Squeak-${VERSION}-src.tar.gz"
+MD5SUM="972e1236a131846fee8b00b7d392ccb4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Stes"
+EMAIL="stes@telenet.be"