summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Isaac Yu2022-04-26 05:09:02 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:51:51 +0200
commit515177bbfaf9d1eb03f011a6f3a5c22920f12c7f (patch)
treee0c03051177be3520f5c2628abb3fa138f73ea6b /development
parentf0cd9244112cabcaa11b13fe592b0800fcb4e7c3 (diff)
downloadslackbuilds-515177bbfaf9d1eb03f011a6f3a5c22920f12c7f.tar.gz
development/jupyter_packaging: Added (Jupyter Packaging Utilities)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter_packaging/README5
-rw-r--r--development/jupyter_packaging/jupyter_packaging.SlackBuild99
-rw-r--r--development/jupyter_packaging/jupyter_packaging.info10
-rw-r--r--development/jupyter_packaging/no-install-tests.patch25
-rw-r--r--development/jupyter_packaging/slack-desc19
5 files changed, 158 insertions, 0 deletions
diff --git a/development/jupyter_packaging/README b/development/jupyter_packaging/README
new file mode 100644
index 0000000000..a9509e62ca
--- /dev/null
+++ b/development/jupyter_packaging/README
@@ -0,0 +1,5 @@
+Jupyter Packaging contains tools to help build and install Jupyter
+Python packages.
+
+jupyter_packaging 0.11.1 is the last possible version for Slackware
+15.0. Newer versions would require a newer python-setuptools.
diff --git a/development/jupyter_packaging/jupyter_packaging.SlackBuild b/development/jupyter_packaging/jupyter_packaging.SlackBuild
new file mode 100644
index 0000000000..6f37a55015
--- /dev/null
+++ b/development/jupyter_packaging/jupyter_packaging.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for jupyter_packaging
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=jupyter_packaging
+VERSION=${VERSION:-0.11.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Don't install tests in site-packages. Patch by mgorny:
+# https://github.com/jupyter/jupyter-packaging/commit/a3b4c9b9.patch
+patch -p1 < $CWD/no-install-tests.patch
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter_packaging/jupyter_packaging.info b/development/jupyter_packaging/jupyter_packaging.info
new file mode 100644
index 0000000000..c7a07054fc
--- /dev/null
+++ b/development/jupyter_packaging/jupyter_packaging.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyter_packaging"
+VERSION="0.11.1"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://pypi.io/packages/source/j/jupyter_packaging/jupyter_packaging-0.11.1.tar.gz"
+MD5SUM="6d39c1382acccdc5dd85ce5702c9ef8f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-deprecation python3-tomlkit wheel"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/development/jupyter_packaging/no-install-tests.patch b/development/jupyter_packaging/no-install-tests.patch
new file mode 100644
index 0000000000..5871685a40
--- /dev/null
+++ b/development/jupyter_packaging/no-install-tests.patch
@@ -0,0 +1,25 @@
+From a3b4c9b9735dee8b407b7cdacc27301bc9af283b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 25 Mar 2022 10:50:03 +0100
+Subject: [PATCH] do not install tests as a top-level package
+
+Explicitly exclude tests from being found by find_packages().
+Otherwise, they are installed as top-level site-packages/tests.
+---
+ setup.cfg | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/setup.cfg b/setup.cfg
+index 9dc7a64..9dc9f11 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -39,5 +39,9 @@ install_requires =
+ [options.extras_require]
+ test = build; coverage; pre-commit; pytest; pytest-cov; pytest-mock
+
++[options.packages.find]
++exclude =
++ tests
++
+ [bdist_wheel]
+ universal=1
diff --git a/development/jupyter_packaging/slack-desc b/development/jupyter_packaging/slack-desc
new file mode 100644
index 0000000000..8d60948ee0
--- /dev/null
+++ b/development/jupyter_packaging/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyter_packaging: jupyter_packaging (Jupyter Packaging Utilities)
+jupyter_packaging:
+jupyter_packaging: Jupyter Packaging contains tools to help build and install Jupyter
+jupyter_packaging: Python packages.
+jupyter_packaging:
+jupyter_packaging:
+jupyter_packaging:
+jupyter_packaging:
+jupyter_packaging:
+jupyter_packaging:
+jupyter_packaging: