summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Isaac Yu2022-04-29 11:20:52 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:51:55 +0200
commit36e20d1f35b5c3a0e26936f23118634779cc22f2 (patch)
treea5b7253d42d442136ac007c6ea6ffc5547054d95 /development
parentc041106118e310241f9eeac53cd305b4bd94d861 (diff)
downloadslackbuilds-36e20d1f35b5c3a0e26936f23118634779cc22f2.tar.gz
development/jupyterlab_server: Added (Launch a JupyterLab app)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyterlab_server/README4
-rw-r--r--development/jupyterlab_server/jupyterlab_server.SlackBuild95
-rw-r--r--development/jupyterlab_server/jupyterlab_server.info10
-rw-r--r--development/jupyterlab_server/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/development/jupyterlab_server/README b/development/jupyterlab_server/README
new file mode 100644
index 0000000000..6659243304
--- /dev/null
+++ b/development/jupyterlab_server/README
@@ -0,0 +1,4 @@
+JupyterLab Server sits between JupyterLab and Jupyter Server, and
+provides a set of REST API handlers and utilities that are used by
+JupyterLab. It is a separate project in order to accommodate creating
+JupyterLab-like applications from a more limited scope.
diff --git a/development/jupyterlab_server/jupyterlab_server.SlackBuild b/development/jupyterlab_server/jupyterlab_server.SlackBuild
new file mode 100644
index 0000000000..bb72b4dd68
--- /dev/null
+++ b/development/jupyterlab_server/jupyterlab_server.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for jupyterlab_server
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=jupyterlab_server
+VERSION=${VERSION:-2.13.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyterlab_server/jupyterlab_server.info b/development/jupyterlab_server/jupyterlab_server.info
new file mode 100644
index 0000000000..bd8ca0db1b
--- /dev/null
+++ b/development/jupyterlab_server/jupyterlab_server.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyterlab_server"
+VERSION="2.13.0"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab_server/jupyterlab_server-2.13.0.tar.gz"
+MD5SUM="8652cc0cb628ece1f4cb5fe7bf005900"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jupyter_server python3-babel python3-json5"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/development/jupyterlab_server/slack-desc b/development/jupyterlab_server/slack-desc
new file mode 100644
index 0000000000..9887eca878
--- /dev/null
+++ b/development/jupyterlab_server/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyterlab_server: jupyterlab_server (Launch an application built using JupyterLab)
+jupyterlab_server:
+jupyterlab_server: JupyterLab Server sits between JupyterLab and Jupyter Server, and
+jupyterlab_server: provides a set of REST API handlers and utilities that are used by
+jupyterlab_server: JupyterLab. It is a separate project in order to accommodate creating
+jupyterlab_server: JupyterLab-like applications from a more limited scope.
+jupyterlab_server:
+jupyterlab_server:
+jupyterlab_server:
+jupyterlab_server:
+jupyterlab_server: