summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 19:17:09 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:50 +0100
commit9a8f94c1bdb4833d894491d641032f75657b3d7f (patch)
treec0bd557b01e08d66e6353fb2a3cb4232f8f832af /development
parent6167bc13a2bbc15b2ab88fd358db6ff6d6be22b6 (diff)
downloadslackbuilds-9a8f94c1bdb4833d894491d641032f75657b3d7f.tar.gz
development/jupyter-nbdime: Removed (abandoned).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter-nbdime/README9
-rw-r--r--development/jupyter-nbdime/jupyter-nbdime.SlackBuild99
-rw-r--r--development/jupyter-nbdime/jupyter-nbdime.info10
-rw-r--r--development/jupyter-nbdime/slack-desc19
4 files changed, 0 insertions, 137 deletions
diff --git a/development/jupyter-nbdime/README b/development/jupyter-nbdime/README
deleted file mode 100644
index afc1c3e48c..0000000000
--- a/development/jupyter-nbdime/README
+++ /dev/null
@@ -1,9 +0,0 @@
-nbdime provides tools for diffing and merging of Jupyter Notebooks.
-
- * nbdiff: compare notebooks in a terminal-friendly way
- * nbmerge: 3-way merge of notebooks with automatic conflict resolution
- * nbdiff-web: shows you a rich rendered diff of notebooks
- * nbmerge-web: gives you a web-based three-way merge tool for notebooks
- * nbshow: presents a single notebook in a terminal-friendly way
-
-All dependencies must be built with support for Python 3.
diff --git a/development/jupyter-nbdime/jupyter-nbdime.SlackBuild b/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
deleted file mode 100644
index fdbc3a973a..0000000000
--- a/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for jupyter-nbdime
-
-# Copyright 2017-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=jupyter-nbdime
-VERSION=${VERSION:-2.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=nbdime
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CONTRIBUTING.md LICENSE.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter-nbdime/jupyter-nbdime.info b/development/jupyter-nbdime/jupyter-nbdime.info
deleted file mode 100644
index e74ba47a2d..0000000000
--- a/development/jupyter-nbdime/jupyter-nbdime.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jupyter-nbdime"
-VERSION="2.1.0"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbdime/nbdime-2.1.0.tar.gz"
-MD5SUM="780c6d17abe4048dea1774a378fa2db7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="colorama GitPython jupyter-notebook python3-gitdb2"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter-nbdime/slack-desc b/development/jupyter-nbdime/slack-desc
deleted file mode 100644
index 5d47ba6d69..0000000000
--- a/development/jupyter-nbdime/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jupyter-nbdime: jupyter-nbdime (Jupyter notebook diff and merge tools)
-jupyter-nbdime:
-jupyter-nbdime: nbdime provides tools for diffing and merging of Jupyter Notebooks.
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime:
-jupyter-nbdime: