summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author LukenShiro2013-11-11 16:13:05 +0100
committer Robby Workman2013-11-11 17:53:36 +0100
commit8a720b7565ebb622a1c75889a9266eb31f3f1305 (patch)
treedee479bddefca7ee732eac31503e5e512e5d34a5 /development
parent192892025092432f653c2c3c8f8ccbadc381d7ee (diff)
downloadslackbuilds-8a720b7565ebb622a1c75889a9266eb31f3f1305.tar.gz
various: fixes for new templates (find/fixperms)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/easygui/easygui.SlackBuild8
-rw-r--r--development/pychecker/pychecker.SlackBuild10
-rw-r--r--development/re2c/re2c.SlackBuild8
3 files changed, 15 insertions, 11 deletions
diff --git a/development/easygui/easygui.SlackBuild b/development/easygui/easygui.SlackBuild
index 68d266800b..25dfad377a 100644
--- a/development/easygui/easygui.SlackBuild
+++ b/development/easygui/easygui.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=easygui
VERSION=${VERSION:-0.96}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${SRC_VERSION}.tar.gz
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# install .py source file and sample file
python ./setup.py build install --root=$PKG
diff --git a/development/pychecker/pychecker.SlackBuild b/development/pychecker/pychecker.SlackBuild
index 31ebc7bf94..b864555786 100644
--- a/development/pychecker/pychecker.SlackBuild
+++ b/development/pychecker/pychecker.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pychecker
-# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2011 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pychecker
VERSION=${VERSION:-0.8.19}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,7 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# setup.py modifications to avoid docfiles' installation in pythondir
sed -i "s|'data_files'|#'data_files'|g" setup.py
diff --git a/development/re2c/re2c.SlackBuild b/development/re2c/re2c.SlackBuild
index 7b80b233ab..bb235f5a2e 100644
--- a/development/re2c/re2c.SlackBuild
+++ b/development/re2c/re2c.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=re2c
VERSION=${VERSION:-0.13.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# --htmldir= is ignored
CFLAGS="$SLKCFLAGS" \