summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Kyle Guinn2019-06-21 05:42:03 +0200
committer Willy Sudiarto Raharjo2019-06-29 03:17:56 +0200
commit9befa1df191843b0ebe88ba7dda65640ece2a232 (patch)
tree6bd0712b45b94c9d17ea91c355f95b6f6cd248fa /development
parent85b9251725c7ac87b1907fc63bb9ed3b324e93c0 (diff)
downloadslackbuilds-9befa1df191843b0ebe88ba7dda65640ece2a232.tar.gz
development/sdcc: Updated for version 3.9.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'development')
-rw-r--r--development/sdcc/README14
-rw-r--r--development/sdcc/patches/source-tree.patch6
-rw-r--r--development/sdcc/sdcc.SlackBuild11
-rw-r--r--development/sdcc/sdcc.info6
-rw-r--r--development/sdcc/slack-desc16
5 files changed, 29 insertions, 24 deletions
diff --git a/development/sdcc/README b/development/sdcc/README
index 5d908ecb77..9b80f85b51 100644
--- a/development/sdcc/README
+++ b/development/sdcc/README
@@ -1,7 +1,11 @@
-SDCC is a retargettable, optimizing ANSI - C compiler that targets the Intel
-8051, Maxim 80DS390, Zilog Z80 and the Motorola 68HC08 based MCUs. Work is in
-progress on supporting the Microchip PIC16 and PIC18 series. SDCC is Free Open
-Source Software, distributed under GNU General Public License (GPL).
+SDCC is a retargettable, optimizing Standard C (ANSI C89, ISO C99, ISO C11)
+compiler suite that targets the Intel MCS51 based microprocessors (8031, 8032,
+8051, 8052, etc.), Maxim (formerly Dallas) DS80C390 variants, Freescale
+(formerly Motorola) HC08 based (hc08, s08), Zilog Z80 based MCUs (z80, z180,
+gbz80, Rabbit 2000/3000, Rabbit 3000A, TLCS-90), Padauk (pdk14, pdk15) and
+STMicroelectronics STM8. Work is in progress on supporting the Padauk (pdk13),
+Microchip PIC16 and PIC18 targets. It can be retargeted for other
+microprocessors.
-By default, this will build sdcc without pic support. If you want that, install
+By default, this will build sdcc without pic support. If you want that, install
gputils and run the script as follows: ENABLE_PIC=y sh ./sdcc.SlackBuild
diff --git a/development/sdcc/patches/source-tree.patch b/development/sdcc/patches/source-tree.patch
index efcf1c7102..cb5d8d813b 100644
--- a/development/sdcc/patches/source-tree.patch
+++ b/development/sdcc/patches/source-tree.patch
@@ -1,10 +1,10 @@
diff --git a/device/lib/Makefile.in b/device/lib/Makefile.in
--- a/device/lib/Makefile.in
+++ b/device/lib/Makefile.in
-@@ -540,19 +540,11 @@
- $(CP_U) -r $(MODELS) mcs51 ds390 ds400 z80 z180 r2k r3ka tlcs90 gbz80 hc08 s08 stm8 $(sdcc_libdir)/src
+@@ -583,19 +583,11 @@
+ $(CP_U) -r $(MODELS) mcs51 ds390 ds400 z80 z180 ez80_z80 r2k r3ka tlcs90 gbz80 hc08 s08 stm8 pdk14 pdk15 $(sdcc_libdir)/src
- for src in $(MODELS) ds390 ds400 z80 z180 r2k r3ka tlcs90 gbz80 hc08 s08 stm8 pic14 pic16; do \
+ for src in $(MODELS) ds390 ds400 z80 z180 ez80_z80 r2k r3ka tlcs90 gbz80 hc08 s08 stm8 pdk14 pdk15 pic14 pic16; do \
- find $(sdcc_libdir)/src/$$src -depth \
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'autom4te.cache' -o \
diff --git a/development/sdcc/sdcc.SlackBuild b/development/sdcc/sdcc.SlackBuild
index d525f39e14..9a9fdf5f1f 100644
--- a/development/sdcc/sdcc.SlackBuild
+++ b/development/sdcc/sdcc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sdcc
-# Copyright 2014-2018 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sdcc
-VERSION=${VERSION:-3.8.0}
+VERSION=${VERSION:-3.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,9 +76,10 @@ chmod -x device/lib/isinf.c device/lib/isnan.c
# A few Makefiles install (copy) the source tree _after_ building, and
# accidentally install a bunch of build byproducts which they try to clean
# up afterwards. Delete some byproducts that they missed.
-for patch in $CWD/patches/* ; do
- patch -p1 < $patch
-done
+patch -p1 < $CWD/patches/source-tree.patch
+
+# Avoid creating empty man directories.
+sed -i '/(man1dir)/d' sim/ucsim/doc/Makefile.in
# Requires lyx, latex2html, possibly others. Untested.
if [ "${ENABLE_DOC:-no}" != 'no' ]; then
diff --git a/development/sdcc/sdcc.info b/development/sdcc/sdcc.info
index 48d92136af..7d3d06ddd5 100644
--- a/development/sdcc/sdcc.info
+++ b/development/sdcc/sdcc.info
@@ -1,8 +1,8 @@
PRGNAM="sdcc"
-VERSION="3.8.0"
+VERSION="3.9.0"
HOMEPAGE="http://sdcc.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/project/sdcc/sdcc/3.8.0/sdcc-src-3.8.0.tar.bz2"
-MD5SUM="31d0d3db8a157018e3df530c50a3974e"
+DOWNLOAD="https://sourceforge.net/projects/sdcc/files/sdcc/3.9.0/sdcc-src-3.9.0.tar.bz2"
+MD5SUM="e50fc62cd9cdfa977af536dfd2d99351"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/sdcc/slack-desc b/development/sdcc/slack-desc
index ea0924e273..fabcddda7f 100644
--- a/development/sdcc/slack-desc
+++ b/development/sdcc/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
sdcc: sdcc (Small Device C Compiler)
sdcc:
-sdcc: SDCC is a retargettable, optimizing ANSI - C compiler that targets the
-sdcc: Intel 8051, Maxim 80DS390, Zilog Z80 and the Motorola 68HC08 based
-sdcc: MCUs. SDCC is Free Open Source Software, distributed under GPL.
-sdcc:
-sdcc: Homepage:http://sdcc.sourceforge.net/
-sdcc:
-sdcc:
-sdcc:
+sdcc: SDCC is a retargettable, optimizing Standard C (ANSI C89, ISO C99, ISO
+sdcc: C11) compiler suite that targets the Intel MCS51 based microprocessors
+sdcc: (8031, 8032, 8051, 8052, etc.), Maxim (formerly Dallas) DS80C390
+sdcc: variants, Freescale (formerly Motorola) HC08 based (hc08, s08), Zilog
+sdcc: Z80 based MCUs (z80, z180, gbz80, Rabbit 2000/3000, Rabbit 3000A,
+sdcc: TLCS-90), Padauk (pdk14, pdk15) and STMicroelectronics STM8. Work is
+sdcc: in progress on supporting the Padauk (pdk13), Microchip PIC16 and
+sdcc: PIC18 targets. It can be retargeted for other microprocessors.
sdcc: