summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Andrew Clemons2019-07-13 23:49:04 +0200
committer Willy Sudiarto Raharjo2019-07-20 11:20:35 +0200
commit900d91cdba58124f0beba199b12fe8ddbfc070f8 (patch)
treeacfafb123cded3136ba2ef1448f85cb14a1d712a /development
parent69862cca3b38d517e9f927f0c46aa0355ba1e7f9 (diff)
downloadslackbuilds-900d91cdba58124f0beba199b12fe8ddbfc070f8.tar.gz
development/mrustc: Updated for version 0.8.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'development')
-rw-r--r--development/mrustc/mrustc-0.8.0-fix-variable-length-integer-receiving.patch15
-rw-r--r--development/mrustc/mrustc.SlackBuild23
-rw-r--r--development/mrustc/mrustc.info6
3 files changed, 26 insertions, 18 deletions
diff --git a/development/mrustc/mrustc-0.8.0-fix-variable-length-integer-receiving.patch b/development/mrustc/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
new file mode 100644
index 0000000000..9e76653a07
--- /dev/null
+++ b/development/mrustc/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
@@ -0,0 +1,15 @@
+https://github.com/thepowersgang/mrustc/issues/109
+From: Danny Milosavljevic <dannym@scratchpost.org>
+Date: Fri, 3 Jan 2019 13:00:00 +0100
+
+--- mrustc/src/expand/proc_macro.cpp.orig 2019-02-01 14:16:54.208486062 +0100
++++ mrustc/src/expand/proc_macro.cpp 2019-02-01 14:17:14.350925705 +0100
+@@ -977,7 +977,7 @@
+ for(;;)
+ {
+ auto b = recv_u8();
+- v |= static_cast<uint64_t>(b) << ofs;
++ v |= static_cast<uint64_t>(b & 0x7F) << ofs;
+ if( (b & 0x80) == 0 )
+ break;
+ ofs += 7;
diff --git a/development/mrustc/mrustc.SlackBuild b/development/mrustc/mrustc.SlackBuild
index 1f1a64d468..909bcb38ae 100644
--- a/development/mrustc/mrustc.SlackBuild
+++ b/development/mrustc/mrustc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mrustc
-# Copyright 2017-2018 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2019 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mrustc
-GITREV=${GITREV:-346da1865a49d7fd354e7aa4e8b5712a2df35a22}
-VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
+VERSION=${VERSION:-0.8.0}
RUSTCVERSION=${RUSTCVERSION:-1.19.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,14 +75,16 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$GITREV
-tar xvf $CWD/$PRGNAM-$GITREV.tar.gz
-cd $PRGNAM-$GITREV
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
-cp $CWD/rustc-$RUSTCVERSION-src.tar.xz .
+patch -p1 < "$CWD/mrustc-0.8.0-fix-variable-length-integer-receiving.patch"
sed -i '/curl -sS https:/d' Makefile
sed -i 's/-src.tar.gz/-src.tar.xz/' Makefile
+cp "$CWD/rustc-$RUSTCVERSION-src.tar.xz" .
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -93,16 +94,9 @@ find -L . \
make RUSTCSRC
-LLVM_TARGETS="X86"
-
-if [ "$ARCH" = "arm" ] ; then
- LLVM_TARGETS="$LLVM_TARGETS;ARM"
-fi
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
RUSTC_TARGET="$RUSTC_TARGET" \
-LLVM_TARGETS="$LLVM_TARGETS" \
CC=gcc \
make -f minicargo.mk
@@ -112,7 +106,6 @@ if [ "$WITH_RUSTC" = "yes" ] ; then
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
RUSTC_TARGET="$RUSTC_TARGET" \
- LLVM_TARGETS="$LLVM_TARGETS" \
CC=gcc \
make -j1 -C run_rustc
fi
diff --git a/development/mrustc/mrustc.info b/development/mrustc/mrustc.info
index d1c9dde249..48936cbb7d 100644
--- a/development/mrustc/mrustc.info
+++ b/development/mrustc/mrustc.info
@@ -1,9 +1,9 @@
PRGNAM="mrustc"
-VERSION="git346da18"
+VERSION="0.8.0"
HOMEPAGE="https://github.com/thepowersgang/mrustc"
-DOWNLOAD="https://github.com/thepowersgang/mrustc/archive/346da1865a49d7fd354e7aa4e8b5712a2df35a22/mrustc-346da1865a49d7fd354e7aa4e8b5712a2df35a22.tar.gz \
+DOWNLOAD="https://github.com/thepowersgang/mrustc/archive/v0.8.0/mrustc-0.8.0.tar.gz \
https://static.rust-lang.org/dist/rustc-1.19.0-src.tar.xz"
-MD5SUM="58ad7b9da4c756e8737fc0c4c5a93b3a \
+MD5SUM="c082e1e2d2258c1481d4bf492bf435ae \
e9af5bb321c0cad44ea0e3e2c644ab2f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""