summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Leo C2019-06-29 00:58:28 +0200
committer Willy Sudiarto Raharjo2019-06-29 00:58:28 +0200
commit89270fbefd286a246dde7d00de463a548ba85db8 (patch)
tree057269b0c8ff4c888fe6117e1a2af56e5faf1bc9 /development
parentbe6813fa885e8c3c01740e8c4c946ac22da70bb0 (diff)
downloadslackbuilds-89270fbefd286a246dde7d00de463a548ba85db8.tar.gz
development/python-docopt: Updated for version 0.6.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/python-docopt/README9
-rw-r--r--development/python-docopt/python-docopt.SlackBuild93
-rw-r--r--development/python-docopt/python-docopt.info10
-rw-r--r--development/python-docopt/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/development/python-docopt/README b/development/python-docopt/README
new file mode 100644
index 0000000000..085b06a386
--- /dev/null
+++ b/development/python-docopt/README
@@ -0,0 +1,9 @@
+docopt helps you:
+- define the interface for your command-line app, and
+- automatically generate a parser for it.
+docopt is based on conventions that have been used for decades in help
+messages and man pages for describing a program's interface.
+An interface description in docopt is such a help message,
+but formalized.
+
+python3 is an optional (autodetected) dependency.
diff --git a/development/python-docopt/python-docopt.SlackBuild b/development/python-docopt/python-docopt.SlackBuild
new file mode 100644
index 0000000000..725340e6ec
--- /dev/null
+++ b/development/python-docopt/python-docopt.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for python-docopt
+
+# Copyright 2019 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-docopt
+VERSION=${VERSION:-0.6.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=${SRCNAM:-docopt}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE-MIT README.rst TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/python-docopt/python-docopt.info b/development/python-docopt/python-docopt.info
new file mode 100644
index 0000000000..968f150038
--- /dev/null
+++ b/development/python-docopt/python-docopt.info
@@ -0,0 +1,10 @@
+PRGNAM="python-docopt"
+VERSION="0.6.2"
+HOMEPAGE="http://docopt.org/"
+DOWNLOAD="https://github.com/docopt/docopt/archive/0.6.2/docopt-0.6.2.tar.gz"
+MD5SUM="a6c44155426fd0f7def8b2551d02fef6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/development/python-docopt/slack-desc b/development/python-docopt/slack-desc
new file mode 100644
index 0000000000..45098cbe30
--- /dev/null
+++ b/development/python-docopt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-docopt: python-docopt (Pythonic command line arguments parser)
+python-docopt:
+python-docopt: docopt helps you:
+python-docopt: - define the interface for your command-line app, and
+python-docopt: - automatically generate a parser for it.
+python-docopt: docopt is based on conventions that have been used for decades in help
+python-docopt: messages and man pages for describing a program's interface.
+python-docopt: An interface description in docopt is such a help message,
+python-docopt: but formalized.
+python-docopt:
+python-docopt: Homepage: http://docopt.org/