summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-04-02 08:51:31 +0200
committer Willy Sudiarto Raharjo2019-04-06 02:02:58 +0200
commit7dc95641e38847053f6cf1c09f5138b9ad5e52b8 (patch)
tree0c7c7048096613c5715ab979b2e08c711a7a2584 /development
parenta48f812e4dcb87a6abc7d91b094c9771180a8657 (diff)
downloadslackbuilds-7dc95641e38847053f6cf1c09f5138b9ad5e52b8.tar.gz
development/Sphinx: Updated for version 2.0.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'development')
-rw-r--r--development/Sphinx/README3
-rw-r--r--development/Sphinx/Sphinx.SlackBuild8
-rw-r--r--development/Sphinx/Sphinx.info8
3 files changed, 10 insertions, 9 deletions
diff --git a/development/Sphinx/README b/development/Sphinx/README
index e5644a5a0e..ab99583992 100644
--- a/development/Sphinx/README
+++ b/development/Sphinx/README
@@ -2,3 +2,6 @@ Sphinx is a tool that translates a set of reStructuredText source files into
various output formats, including HTML, ePub, LaTeX and plain text. Sphinx was
originally created for the Python documentation, but it has excellent
facilities for the documentation of software projects in a range of languages.
+
+All Sphinx dependencies must be built with Python 3 support, which usually just
+means making sure that python3 is installed before building them.
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
index f4fee9d1ec..863938e3de 100644
--- a/development/Sphinx/Sphinx.SlackBuild
+++ b/development/Sphinx/Sphinx.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Sphinx
-VERSION=${VERSION:-1.8.4}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,16 +56,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-PYTHONPATH="../" make -C doc SPHINXBUILD="python $PKG/usr/bin/sphinx-build" html
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS CHANGES EXAMPLES LICENSE README.rst doc/_build/html \
+ AUTHORS CHANGES EXAMPLES LICENSE README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
index 0cb3ff28ae..23afee8d3b 100644
--- a/development/Sphinx/Sphinx.info
+++ b/development/Sphinx/Sphinx.info
@@ -1,10 +1,10 @@
PRGNAM="Sphinx"
-VERSION="1.8.4"
+VERSION="2.0.0"
HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-1.8.4.tar.gz"
-MD5SUM="8466f512322e81ef2f4da4d1ba61ff2f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-2.0.0.tar.gz"
+MD5SUM="725b95c6e7baec69e0e6c193ab501134"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="alabaster babel docutils imagesize Jinja2 packaging Pygments python-requests snowballstemmer sphinxcontrib-websupport typing"
+REQUIRES="alabaster imagesize python3-babel python3-Jinja2 python3-packaging python3-Pygments python-requests python3-six snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"