summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Andrew Clemons2018-04-12 02:45:29 +0200
committer Willy Sudiarto Raharjo2018-04-14 02:06:30 +0200
commit02a97b089a32104354946221b4f0e9df966c55ae (patch)
treea5f15b9c0b1f70434933f01be4c66d003b114db0 /development
parent7a49f5c78d15b0499dab931cd70f2bd0f8e60152 (diff)
downloadslackbuilds-02a97b089a32104354946221b4f0e9df966c55ae.tar.gz
development/mrustc: Added (Alternative rust compiler).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/mrustc/README13
-rw-r--r--development/mrustc/mrustc.SlackBuild122
-rw-r--r--development/mrustc/mrustc.info12
-rw-r--r--development/mrustc/slack-desc19
4 files changed, 166 insertions, 0 deletions
diff --git a/development/mrustc/README b/development/mrustc/README
new file mode 100644
index 0000000000..0a4fb047ec
--- /dev/null
+++ b/development/mrustc/README
@@ -0,0 +1,13 @@
+mrustc - alternative rust compiler
+
+This project is an attempt at creating a simple rust compiler in C++, with the
+ultimate goal of being a separate re-implementation.
+
+This slackbuild will build and package mrustc and additionally build the
+official rust 1.19.0 with stdlib.
+
+This script may take a while to complete (around one hour a 10 core machine)
+and will require about 18GB (!) of disk space for its temporary directory. It
+defaults to "/tmp/SBo" and you may redefine it like this:
+
+TMP=/your/temporary/dir ./mrustc.SlackBuild
diff --git a/development/mrustc/mrustc.SlackBuild b/development/mrustc/mrustc.SlackBuild
new file mode 100644
index 0000000000..86219fb95f
--- /dev/null
+++ b/development/mrustc/mrustc.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/sh
+
+# Slackware build script for mrustc
+
+# Copyright 2017-2018 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mrustc
+GITREV=${GITREV:-4f98e4322ef7aabd3bbef8cd93c0980cd6eeeed1}
+VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
+RUSTCVERSION=${RUSTCVERSION:-1.19.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# https://github.com/thepowersgang/mrustc/issues/38#issuecomment-352158861
+if [ "$ARCH" != "x86_64" ]; then
+ echo "Sorry, mrustc currently only supports x86_64."
+ exit 1
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$GITREV
+tar xvf $CWD/$PRGNAM-$GITREV.tar.gz
+cd $PRGNAM-$GITREV
+
+cp $CWD/rustc-$RUSTCVERSION-src.tar.xz .
+sed -i '/curl -sS https:/d' Makefile
+sed -i 's/-src.tar.gz/-src.tar.xz/' Makefile
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+make RUSTCSRC
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make -f minicargo.mk
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make -j1 -C run_rustc
+
+mkdir -p $PKG/usr/bin
+install -m 0755 bin/mrustc $PKG/usr/bin/mrustc
+install -m 0755 tools/bin/minicargo $PKG/usr/bin/minicargo
+
+mkdir -p $PKG/usr/share/mrustc
+find output -name '*.hir' -maxdepth 1 -exec install -m 0644 {} $PKG/usr/share/mrustc/ \;
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/rustlib/$ARCH-unknown-linux-gnu/lib/
+cp -a run_rustc/prefix/lib/rustlib/$ARCH-unknown-linux-gnu/lib/* $PKG/usr/lib$LIBDIRSUFFIX/rustlib/$ARCH-unknown-linux-gnu/lib/
+
+install -m 0755 output/rustc $PKG/usr/bin/rustc
+install -m 0755 output/cargo $PKG/usr/bin/cargo
+install -m 0755 output/rustc-build/rustdoc $PKG/usr/bin/rustdoc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENCE-MIT README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/mrustc/mrustc.info b/development/mrustc/mrustc.info
new file mode 100644
index 0000000000..4024f19a66
--- /dev/null
+++ b/development/mrustc/mrustc.info
@@ -0,0 +1,12 @@
+PRGNAM="mrustc"
+VERSION="git4f98e43"
+HOMEPAGE="https://github.com/thepowersgang/mrustc"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://github.com/thepowersgang/mrustc/archive/4f98e4322ef7aabd3bbef8cd93c0980cd6eeeed1/mrustc-4f98e4322ef7aabd3bbef8cd93c0980cd6eeeed1.tar.gz \
+ https://static.rust-lang.org/dist/rustc-1.19.0-src.tar.xz"
+MD5SUM_x86_64="f73f9070c637b181eb9944c5d809e714 \
+ e9af5bb321c0cad44ea0e3e2c644ab2f"
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/development/mrustc/slack-desc b/development/mrustc/slack-desc
new file mode 100644
index 0000000000..d087965b44
--- /dev/null
+++ b/development/mrustc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mrustc: mrustc (Alternative rust compiler)
+mrustc:
+mrustc: Mutabah's Rust Compiler
+mrustc:
+mrustc: In-progress alternative rust compiler.
+mrustc:
+mrustc: https://github.com/thepowersgang/mrustc
+mrustc:
+mrustc:
+mrustc:
+mrustc: