summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Kyle Guinn2017-06-30 04:24:57 +0200
committer Willy Sudiarto Raharjo2017-07-01 02:42:14 +0200
commit2ce0cb478ff710606f93ffc665b262ad831f5c96 (patch)
tree9947fa0a72a285b2cb98ac634349aee8bdb6e9e6 /development
parentb60615cf24a52dd6322e1f4c1f14f982e44fed10 (diff)
downloadslackbuilds-2ce0cb478ff710606f93ffc665b262ad831f5c96.tar.gz
development/cppunit: Updated for version 1.14.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'development')
-rw-r--r--development/cppunit/README9
-rw-r--r--development/cppunit/cppunit.SlackBuild25
-rw-r--r--development/cppunit/cppunit.info8
3 files changed, 29 insertions, 13 deletions
diff --git a/development/cppunit/README b/development/cppunit/README
index 5ceecf9e8f..1b55f72a26 100644
--- a/development/cppunit/README
+++ b/development/cppunit/README
@@ -1 +1,10 @@
CppUnit is a C++ unit testing framework.
+
+Starting with version 1.14.0, cppunit may require that your tests be compiled
+with a C++11-conforming compiler (e.g. by adding the -std=c++11 flag to g++).
+Since this is not yet the default for g++, if you intend on using cppunit with
+projects that do not yet mandate C++11, then you may want to stick with an
+older version.
+
+graphviz is an optional dependency. It will be used when creating the
+Doxygen documentation if found.
diff --git a/development/cppunit/cppunit.SlackBuild b/development/cppunit/cppunit.SlackBuild
index 073cc84cd3..c1437f07ad 100644
--- a/development/cppunit/cppunit.SlackBuild
+++ b/development/cppunit/cppunit.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for CppUnit
-# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2017 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cppunit
-VERSION=${VERSION:-1.13.2}
+VERSION=${VERSION:-1.14.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;;
esac
@@ -40,11 +40,15 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="AUTHORS BUGS COPYING ChangeLog CodingGuideLines.txt INSTALL* NEWS README THANKS TODO"
+# Makefile.am handles AUTHORS, BUGS, CodingGuideLines.txt, INSTALL*, doc/FAQ
+DOCS="COPYING ChangeLog NEWS README THANKS TODO"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
@@ -67,28 +71,31 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
+# Fix a typo that breaks dot/graphviz detection.
+sed -i 's/xenable_dot/x$enable_dot/' m4/bb_enable_doxygen.m4
# Make it respect --htmldir.
sed -i '/^htmldir/d' doc/Makefile.am
autoreconf -vif
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--htmldir=/usr/doc/$PRGNAM-$VERSION/html \
- --build=$ARCH-slackware-linux \
--disable-static \
- --disable-dependency-tracking
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux \
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
make
make install-strip DESTDIR=$PKG
-find $PKG/usr/man -type f -exec gzip -9 {} +
+find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/development/cppunit/cppunit.info b/development/cppunit/cppunit.info
index 4a4032f15f..40159682e0 100644
--- a/development/cppunit/cppunit.info
+++ b/development/cppunit/cppunit.info
@@ -1,8 +1,8 @@
PRGNAM="cppunit"
-VERSION="1.13.2"
-HOMEPAGE="http://freedesktop.org/wiki/Software/cppunit/"
-DOWNLOAD="http://dev-www.libreoffice.org/src/cppunit-1.13.2.tar.gz"
-MD5SUM="d1c6bdd5a76c66d2c38331e2d287bc01"
+VERSION="1.14.0"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit/"
+DOWNLOAD="https://dev-www.libreoffice.org/src/cppunit-1.14.0.tar.gz"
+MD5SUM="7ad93022171710a541bfe4bfd8b4a381"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""