summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Anton S. Abanin2012-12-20 14:12:33 +0100
committer Matteo Bernardini2012-12-20 14:12:51 +0100
commit673adb97550dbfb6e73b62feb888e566d84f64b8 (patch)
tree98d6a7bfb141f056ae0521993bb6deef5e78d2bb /development
parent294feb59e5b3c9b2a258eb711a47868647da59dd (diff)
downloadslackbuilds-673adb97550dbfb6e73b62feb888e566d84f64b8.tar.gz
development/pyclewn: Added (vim as a debugger frontend).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/pyclewn/README18
-rw-r--r--development/pyclewn/doinst.sh1
-rw-r--r--development/pyclewn/pyclewn.SlackBuild78
-rw-r--r--development/pyclewn/pyclewn.info10
-rw-r--r--development/pyclewn/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/development/pyclewn/README b/development/pyclewn/README
new file mode 100644
index 0000000000..8ea36a0a7f
--- /dev/null
+++ b/development/pyclewn/README
@@ -0,0 +1,18 @@
+Pyclewn allows using vim as a front end to a debugger.
+Pyclewn currently supports gdb and pdb.
+
+The debugger output is redirected to a vim window,
+the pyclewn console. The debugger commands are mapped to vim
+user-defined commands with a common letter prefix, and with completion
+available on the commands and their first argument.
+
+When running gvim, the controlling terminal of the program to debug is
+the terminal used to launch pyclewn. Any other terminal can be used
+when the debugger allows it, for example after using the attach or tty
+gdb commands or using the --tty option with pdb.
+
+Required Vim 7.0 or above with the netbeans_intg feature enabled,
+and with the autocmd feature enabled.
+
+You can use the :help pyclewn command within vim, to get access
+to the documentation.
diff --git a/development/pyclewn/doinst.sh b/development/pyclewn/doinst.sh
new file mode 100644
index 0000000000..2c7ff8c9e9
--- /dev/null
+++ b/development/pyclewn/doinst.sh
@@ -0,0 +1 @@
+/usr/bin/vim -c "helptags /usr/share/vim/vimfiles/doc|q"
diff --git a/development/pyclewn/pyclewn.SlackBuild b/development/pyclewn/pyclewn.SlackBuild
new file mode 100644
index 0000000000..778b893ef6
--- /dev/null
+++ b/development/pyclewn/pyclewn.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for pyclewn
+
+# Written by Anton S. Abanin <warlock66613@gmail.com>
+
+PRGNAM=pyclewn
+VERSION=${VERSION:-1.9.py2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo} # the "_SBo" is required
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+EDITOR=/usr/bin/vim python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog \
+ COPYING \
+ INSTALL \
+ MANIFEST.in \
+ NEWS \
+ PKG-INFO \
+ README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pyclewn/pyclewn.info b/development/pyclewn/pyclewn.info
new file mode 100644
index 0000000000..46dc253879
--- /dev/null
+++ b/development/pyclewn/pyclewn.info
@@ -0,0 +1,10 @@
+PRGNAM="pyclewn"
+VERSION="1.9.py2"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyclewn/pyclewn-1.9.py2.tar.gz"
+MD5SUM="6ba75ca82d2833cffda5b073ad82e2b1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Anton S. Abanin"
+EMAIL="warlock66613@gmail.com"
diff --git a/development/pyclewn/slack-desc b/development/pyclewn/slack-desc
new file mode 100644
index 0000000000..1de7164887
--- /dev/null
+++ b/development/pyclewn/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyclewn: Pyclewn allows using vim as a front end to a debugger (gdb or pdb)
+pyclewn:
+pyclewn: The debugger output is redirected to a vim window,
+pyclewn: the pyclewn console. The debugger commands are mapped to vim
+pyclewn: user-defined commands with a common letter prefix, and with completion
+pyclewn: available on the commands and their first argument.
+pyclewn:
+pyclewn: You can use the :help pyclewn command within vim, to get access
+pyclewn: to the documentation.
+pyclewn:
+pyclewn: Homepage: http://pyclewn.sourceforge.net/