summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Georgi Kolev2013-11-30 16:41:39 +0100
committer Robby Workman2013-12-02 07:58:01 +0100
commit53e171fff78509edcf85dd9fa5b6c435b2ec86a3 (patch)
treed65adc21a33e96245071cc51d9debff0da974f53 /development
parent707ea9c67d7ff53f4c3fa547b6d341212c160c1c (diff)
downloadslackbuilds-53e171fff78509edcf85dd9fa5b6c435b2ec86a3.tar.gz
development/gnuradio: Added (toolkit for building SDRs).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/gnuradio/README10
-rw-r--r--development/gnuradio/doinst.sh13
-rw-r--r--development/gnuradio/gnuradio.SlackBuild111
-rw-r--r--development/gnuradio/gnuradio.info10
-rw-r--r--development/gnuradio/slack-desc19
5 files changed, 163 insertions, 0 deletions
diff --git a/development/gnuradio/README b/development/gnuradio/README
new file mode 100644
index 0000000000..9ac01a083a
--- /dev/null
+++ b/development/gnuradio/README
@@ -0,0 +1,10 @@
+GNU Radio is a free & open-source software development toolkit
+that provides signal processing blocks to implement software radios.
+It can be used with readily-available low-cost external RF hardware
+to create software-defined radios, or without hardware in a
+simulation-like environment. It is widely used in hobbyist, academic
+and commercial environments to support both wireless communications
+research and real-world radio systems.
+
+uhd, cppunit, gsl, lxml, numpy, orc, qwt, wxPython and Sphinx
+(this last to generate additional docs) are optional dependencies.
diff --git a/development/gnuradio/doinst.sh b/development/gnuradio/doinst.sh
new file mode 100644
index 0000000000..19a6ff6ac8
--- /dev/null
+++ b/development/gnuradio/doinst.sh
@@ -0,0 +1,13 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
diff --git a/development/gnuradio/gnuradio.SlackBuild b/development/gnuradio/gnuradio.SlackBuild
new file mode 100644
index 0000000000..0051b276a3
--- /dev/null
+++ b/development/gnuradio/gnuradio.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/sh
+
+# Slackware build script for gnuradio
+
+# Copyright 2013 Georgi Kolev, Bulgaria
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=gnuradio
+VERSION=${VERSION:-3.6.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# install docs in the right place
+sed -i "s|\${GR_DATA_DIR}/doc|doc|" CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSCONFDIR=/etc \
+ -DLIB_SUFFIX=$LIBDIRSUFFIX \
+ -DCMAKE_MODULES_DIR=lib$LIBDIRSUFFIX/cmake/$PRGNAM \
+ -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# don't clobber configuration files
+( cd $PKG
+ for i in $(ls -1 etc/gnuradio/conf.d); do
+ mv etc/gnuradio/conf.d/$i etc/gnuradio/conf.d/$i.new
+ echo "config etc/gnuradio/conf.d/$i.new" >> install/doinst.sh
+ done )
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gnuradio/gnuradio.info b/development/gnuradio/gnuradio.info
new file mode 100644
index 0000000000..c52f1bc77a
--- /dev/null
+++ b/development/gnuradio/gnuradio.info
@@ -0,0 +1,10 @@
+PRGNAM="gnuradio"
+VERSION="3.6.5.1"
+HOMEPAGE="http://gnuradio.org"
+DOWNLOAD="http://gnuradio.org/releases/gnuradio/gnuradio-3.6.5.1.tar.gz"
+MD5SUM="a959b39720776a7af44a27c6820b16fa"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-cheetah"
+MAINTAINER="Georgi Kolev"
+EMAIL="shadowx@escom.bg"
diff --git a/development/gnuradio/slack-desc b/development/gnuradio/slack-desc
new file mode 100644
index 0000000000..b76c95fac6
--- /dev/null
+++ b/development/gnuradio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gnuradio: gnuradio (free software toolkit for building SDRs)
+gnuradio:
+gnuradio: GNU Radio is a free & open-source software development toolkit
+gnuradio: that provides signal processing blocks to implement software
+gnuradio: radios. It can be used with readily-available low-cost external RF
+gnuradio: hardware to create software-defined radios, or without hardware
+gnuradio: in a simulation-like environment. It is widely used in hobbyist,
+gnuradio: academic and commercial environments to support both wireless
+gnuradio: communications research and real-world radio systems.
+gnuradio:
+gnuradio: homepage: http://gnuradio.org