summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Matteo Bernardini2012-09-25 14:39:13 +0200
committer Robby Workman2012-09-26 07:00:45 +0200
commitd5ad0f5d0615b98b5865896be4e8c2adabe926a6 (patch)
tree82d207f17211176f60421f93830e28f4c782fd33 /development
parent656d2dee56f21478a3b7f8b89ba1260b962bfd04 (diff)
downloadslackbuilds-d5ad0f5d0615b98b5865896be4e8c2adabe926a6.tar.gz
development/amaya: Updated for version 11.4.4.
Added the foreign dictionaries, built over the system's raptor and wxPython (so added them as dependencies) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/amaya/amaya.SlackBuild24
-rw-r--r--development/amaya/amaya.info18
-rw-r--r--development/amaya/amaya_gcc45x.patch25
-rw-r--r--development/amaya/newgtk.patch16
-rw-r--r--development/amaya/patches/amaya-fix-thotlib-png14.patch56
-rw-r--r--development/amaya/patches/explicite_linking2.patch24
-rw-r--r--development/amaya/patches/gzread.patch21
7 files changed, 128 insertions, 56 deletions
diff --git a/development/amaya/amaya.SlackBuild b/development/amaya/amaya.SlackBuild
index 6417cea649..f9fd339e87 100644
--- a/development/amaya/amaya.SlackBuild
+++ b/development/amaya/amaya.SlackBuild
@@ -26,8 +26,8 @@
# Modified by the SlackBuilds.org team
PRGNAM=amaya
-VERSION=${VERSION:-11.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-11.4.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,28 +72,24 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Apply a patch so wxWidgets builds with the newer gtk
-( cd wxWidgets ; cat $CWD/newgtk.patch | patch -p1 || exit 1 )
-
-# Apply patch for gcc 4.5.x
-patch -p1 < $CWD/amaya_gcc45x.patch
+# Apply some patches (thanks to archlinux)
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
mkdir -p Amaya/build
cd Amaya/build
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
../configure \
- --prefix=/opt/ \
+ --prefix=/opt \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--with-gl \
- --with-wxsrcdir=../../wxWidgets/ \
+ --enable-system-wx \
--enable-system-raptor \
--build=$ARCH-slackware-linux
- make wxwidgets || exit 1
make all || exit 1
make install DESTDIR=$PKG || exit 1
cd ..
@@ -114,8 +110,14 @@ cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
ln -s ../../../opt/Amaya/resources/icons/misc/logo.png amaya.png
)
+# Install the foreign dictionaries (English and French are already there)
+for i in Dutch German Italian Spanish Swedish ; do tar xf $CWD/$i.tgz ; done
+for i in G I N S W ; do
+ install -m 0644 -D ${i}princ.dic $PKG/opt/Amaya/dicopar/${i}princ.dic
+done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/amaya/amaya.info b/development/amaya/amaya.info
index c07f995841..5719c9ceff 100644
--- a/development/amaya/amaya.info
+++ b/development/amaya/amaya.info
@@ -1,10 +1,20 @@
PRGNAM="amaya"
-VERSION="11.3.1"
+VERSION="11.4.4"
HOMEPAGE="http://www.w3.org/Amaya/"
-DOWNLOAD="http://www.w3.org/Amaya/Distribution/amaya-sources-11.3.1.tgz"
-MD5SUM="4a92b4e043fbd1add5b1e17fb7ed8755"
+DOWNLOAD="http://www.w3.org/Amaya/Distribution/amaya-sources-11.4.4.tgz \
+ http://www.w3.org/Amaya/Distribution/Dutch.tgz \
+ http://www.w3.org/Amaya/Distribution/German.tgz \
+ http://www.w3.org/Amaya/Distribution/Italian.tgz \
+ http://www.w3.org/Amaya/Distribution/Spanish.tgz \
+ http://www.w3.org/Amaya/Distribution/Swedish.tgz"
+MD5SUM="e8072c7b1d06b983951c56e9f51fbacf \
+ 3edb9cce5ce160d7270b23808c1d5981 \
+ 400eeeae974a64d23de4fcdd609c30bc \
+ 05e2d25ee8af11faaaa25a33da89d504 \
+ b504a75cd0f789a3046bf2041067b18b \
+ 6536ab2e31e3f58618ba79d9fddc7f76"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="raptor wxPython"
MAINTAINER="Vincent Batts"
EMAIL="vbatts@hashbangbash.com"
diff --git a/development/amaya/amaya_gcc45x.patch b/development/amaya/amaya_gcc45x.patch
deleted file mode 100644
index e2587e1336..0000000000
--- a/development/amaya/amaya_gcc45x.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- Amaya11.3.1/Amaya/thotlib/base/platform.c 2009-12-02 09:23:07.000000000 -0200
-+++ Amaya11.3.1_patched/Amaya/thotlib/base/platform.c 2011-03-25 00:43:18.000000000 -0300
-@@ -329,9 +329,9 @@
- {
- tmp = (char *)TtaGetMemory (strlen(targetFileName)+10);
- sprintf (tmp, "%s.tmp", targetFileName);
-- wxFile::wxFile (targetFile, wxFile::write);
-+ wxFile (targetFile, wxFile::write);
- tmpFile = TtaConvMessageToWX(tmp);
-- wxFile::wxFile (tmpFile, wxFile::write);
-+ wxFile (tmpFile, wxFile::write);
- result = wxFile::Exists(targetFile);
- if (result)
- result = wxConcatFiles (tmpFile, sourceFile, targetFile);
---- Amaya11.3.1/Amaya/amaya/HTMLedit.c 2009-12-09 08:11:22.000000000 -0200
-+++ Amaya11.3.1_patched/Amaya/amaya/HTMLedit.c 2011-03-25 01:05:24.000000000 -0300
-@@ -1689,7 +1689,7 @@
- {
- #ifdef _WX
- wxString tmpFile = TtaConvMessageToWX(tempURL);
-- wxFile::wxFile (tmpFile, wxFile::write);
-+ wxFile (tmpFile, wxFile::write);
- #endif /* _WX */
- }
- }
diff --git a/development/amaya/newgtk.patch b/development/amaya/newgtk.patch
deleted file mode 100644
index eb8e653c9e..0000000000
--- a/development/amaya/newgtk.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- wxGTK-2.8.10/src/gtk/gsockgtk.cpp 2009-03-06 09:18:08.000000000 -0300
-+++ wxGTK-2.8.10_patched/src/gtk/gsockgtk.cpp 2010-03-27 08:32:57.000000000 -0300
-@@ -15,8 +15,13 @@
- #include <stdlib.h>
- #include <stdio.h>
-
-+// newer versions of glib define its own GSocket but we unfortunately use this
-+// name in our own (semi-)public header and so can't change it -- rename glib
-+// one instead
-+#define GSocket GlibGSocket
- #include <gdk/gdk.h>
- #include <glib.h>
-+#undef GSocket
-
- #include "wx/gsocket.h"
- #include "wx/unix/gsockunx.h"
diff --git a/development/amaya/patches/amaya-fix-thotlib-png14.patch b/development/amaya/patches/amaya-fix-thotlib-png14.patch
new file mode 100644
index 0000000000..2231db2de2
--- /dev/null
+++ b/development/amaya/patches/amaya-fix-thotlib-png14.patch
@@ -0,0 +1,56 @@
+diff -aur Amaya11.3.1/Amaya/thotlib/image/pnghandler.c Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c
+--- Amaya11.3.1/Amaya/thotlib/image/pnghandler.c 2009-09-09 11:54:50.000000000 +0200
++++ Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c 2010-08-17 20:42:10.823505508 +0200
+@@ -10,9 +10,9 @@
+ * R. Guetari (W3C/INRIA) - Initial Windows version
+ */
+
++#include "png.h"
+ #include "thot_gui.h"
+ #include "thot_sys.h"
+-#include "png.h"
+ #include "constmedia.h"
+ #include "typemedia.h"
+ #include "picture.h"
+@@ -128,13 +128,13 @@
+ png_byte **ppbRowPointers;
+ unsigned char *pixels;
+ unsigned int i, j, passes;
+- unsigned long lw, lh;
++ png_uint_32 lw, lh;
+ int iBitDepth, iColorType;
+ double dGamma;
+
+ /* Checks the eight byte PNG signature*/
+ fread (pbSig, 1, 8, pfFile);
+- if (!png_check_sig (pbSig, 8))
++ if (png_sig_cmp (pbSig, 0, 8))
+ return NULL;
+ /* create the two png(-info) structures*/
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING,
+@@ -169,13 +169,13 @@
+ png_set_strip_16 (png_ptr);
+ /* Grayscale =>RGB or RGBA */
+ if (iColorType == PNG_COLOR_TYPE_GRAY || iColorType == PNG_COLOR_TYPE_GRAY_ALPHA)
+- png_set_gray_to_rgb (png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ /* Palette indexed colors to RGB */
+ if (iColorType == PNG_COLOR_TYPE_PALETTE)
+ png_set_palette_to_rgb (png_ptr);
+ /* 8 bits / channel is needed */
+ if (iColorType == PNG_COLOR_TYPE_GRAY && iBitDepth < 8)
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ /* all transparency type : 1 color, indexed => alpha channel*/
+ if (png_get_valid (png_ptr, info_ptr,PNG_INFO_tRNS))
+ png_set_tRNS_to_alpha (png_ptr);
+@@ -822,7 +822,7 @@
+ TtaReadClose (fp);
+ if (ret != 8)
+ return FALSE;
+- ret = png_check_sig ((png_byte*)buf, 8);
++ ret = !png_sig_cmp ((png_byte*)buf, 0, 8);
+ if (ret) return (TRUE);
+ return(FALSE);
+ }
+
diff --git a/development/amaya/patches/explicite_linking2.patch b/development/amaya/patches/explicite_linking2.patch
new file mode 100644
index 0000000000..8219763488
--- /dev/null
+++ b/development/amaya/patches/explicite_linking2.patch
@@ -0,0 +1,24 @@
+diff -Naur Amaya11.3.1.orig/Amaya/amaya/Makefile.in Amaya11.3.1.new/Amaya/amaya/Makefile.in
+--- Amaya11.3.1.orig/Amaya/amaya/Makefile.in 2012-01-14 18:53:00.000000000 +0100
++++ Amaya11.3.1.new/Amaya/amaya/Makefile.in 2012-01-14 18:55:12.000000000 +0100
+@@ -21,7 +21,7 @@
+ $(GL_LIBRARIES) $(GTK_GL_LIBRARIES) $(FREETYPE_LIBRARIES) $(XFT_LIBRARIES) \
+ $(AMAYA_LIBWWW_LIBS) \
+ @AMAYA_RAPTOR_LIBS@ \
+- $(WX_LIBRARIES)
++ $(WX_LIBRARIES) -lpng14 -ljpeg -lexpat -lwwwssl
+
+ AMAYA = @top_srcdir@/amaya
+
+diff -Naur Amaya11.3.1.orig/Amaya/thotlib/Makefile.in Amaya11.3.1.new/Amaya/thotlib/Makefile.in
+--- Amaya11.3.1.orig/Amaya/thotlib/Makefile.in 2012-01-14 18:53:00.000000000 +0100
++++ Amaya11.3.1.new/Amaya/thotlib/Makefile.in 2012-01-14 18:55:45.000000000 +0100
+@@ -351,7 +351,7 @@
+
+ ../bin/print : $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) \
+ ../amaya/libCSS.a
+- $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS)
++ $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS) -lpng14 -ljpeg
+ @$(ECHO) "====>" print is done
+
+ CEXTRACT= ../bin/cextract
diff --git a/development/amaya/patches/gzread.patch b/development/amaya/patches/gzread.patch
new file mode 100644
index 0000000000..c2644dc197
--- /dev/null
+++ b/development/amaya/patches/gzread.patch
@@ -0,0 +1,21 @@
+--- Amaya11.4.4/Amaya/amaya/html2thot.c.old 2012-03-07 10:53:27.904494374 +0100
++++ Amaya11.4.4/Amaya/amaya/html2thot.c 2012-03-07 11:20:46.931113208 +0100
+@@ -4349,7 +4349,7 @@
+ WorkBuffer = FileBuffer;
+ }
+ // need to read a new set of characters
+- LastCharInWorkBuffer = gzread (infile, &FileBuffer[StartOfRead],
++ LastCharInWorkBuffer = gzread ((gzFile) infile, &FileBuffer[StartOfRead],
+ INPUT_FILE_BUFFER_SIZE - StartOfRead);
+ // add previous read characters not managed yet
+ LastCharInWorkBuffer += StartOfRead;
+--- Amaya11.4.4/Amaya/amaya/Xml2thot.c.old 2012-03-07 11:21:30.994445257 +0100
++++ Amaya11.4.4/Amaya/amaya/Xml2thot.c 2012-03-07 11:22:04.644444274 +0100
+@@ -5847,6 +5847,6 @@
+ while (!endOfFile && !XMLNotWellFormed && !XMLInvalidToken)
+ {
+ /* read the XML file */
+- res = gzread (infile, bufferRead, COPY_BUFFER_SIZE);
++ res = gzread ((gzFile) infile, bufferRead, COPY_BUFFER_SIZE);
+ if (res < 0)
+ return;