summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Larry Hajali2011-12-23 03:29:36 +0100
committer Niels Horn2011-12-23 17:05:43 +0100
commit87040b6af56d8944a35142fe2628c2aacbbd802e (patch)
tree051961e5fe12482479f3e3d3471463b2ba4caa32 /development
parenta391e6faecccd2025cda7ffe282b193ff346cc9e (diff)
downloadslackbuilds-87040b6af56d8944a35142fe2628c2aacbbd802e.tar.gz
development/spyder: Added (interactive Python IDE)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/spyder/README6
-rw-r--r--development/spyder/doinst.sh9
-rw-r--r--development/spyder/slack-desc19
-rw-r--r--development/spyder/spyder.SlackBuild88
-rw-r--r--development/spyder/spyder.info10
5 files changed, 132 insertions, 0 deletions
diff --git a/development/spyder/README b/development/spyder/README
new file mode 100644
index 0000000000..99aec41bfc
--- /dev/null
+++ b/development/spyder/README
@@ -0,0 +1,6 @@
+Spyder (previously known as Pydee) is a powerful interactive development
+environment for the Python language with advanced editing, interactive testing,
+debugging and introspection features.
+
+Spyder requires Sphinx. Optional dependencies for spyder are ipython, rope,
+matplotlib, numpy, pyflakes, pep8, pylint and scipy.
diff --git a/development/spyder/doinst.sh b/development/spyder/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/development/spyder/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/development/spyder/slack-desc b/development/spyder/slack-desc
new file mode 100644
index 0000000000..27e223ac7f
--- /dev/null
+++ b/development/spyder/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+spyder: spyder (interactive Python IDE)
+spyder:
+spyder: Spyder (previously known as Pydee) is a powerful interactive
+spyder: development environment for the Python language with advanced editing,
+spyder: interactive testing, debugging and introspection features.
+spyder:
+spyder: Homepage: http://code.google.com/p/spyderlib/
+spyder:
+spyder:
+spyder:
+spyder:
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
new file mode 100644
index 0000000000..b7acc984e8
--- /dev/null
+++ b/development/spyder/spyder.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for spyder
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=spyder
+VERSION=${VERSION:-2.1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Sphinx craps out when files are in Windows format. We need to
+# change doc/conf.py to Unix format. Simple hack! :/
+find . -type f \( ! -iname "*.png" ! -iname "*.svg" ! -iname "*.ico" \) \
+ -exec sed -i 's/\r//g' '{}' \;
+
+# Use the license found in the __init__.py file
+cat spyderlib/__init__.py | head -n 27 | tail -n 25 > LICENSE
+
+# Fix the .desktop item.
+sed -i 's|Science;||' scripts/$PRGNAM.desktop
+printf "\nIcon=$PRGNAM\n" >> scripts/$PRGNAM.desktop
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -D -m 0644 scripts/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+for i in 16 24 32 36 48 64 96 128; do
+ convert spyderlib/images/$PRGNAM.svg -resize ${i}x${i}! $PRGNAM-$i.png
+ install -D -m 0644 $PRGNAM-$i.png $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
+done
+install -D -m 0644 spyderlib/images/$PRGNAM.svg \
+ $PKG/usr/share/icons/hicolor/scalable/apps/$PRGNAM.svg
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/spyder/spyder.info b/development/spyder/spyder.info
new file mode 100644
index 0000000000..86bad5667f
--- /dev/null
+++ b/development/spyder/spyder.info
@@ -0,0 +1,10 @@
+PRGNAM="spyder"
+VERSION="2.1.6"
+HOMEPAGE="http://code.google.com/p/spyderlib/"
+DOWNLOAD="http://spyderlib.googlecode.com/files/spyder-2.1.6.zip"
+MD5SUM="fac1024549d7fccfc6d01448a3b996e2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"