summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author LukenShiro2011-11-01 11:40:58 +0100
committer Niels Horn2011-11-01 11:40:58 +0100
commit5331682a26ab2104f07e1dcc45a6857ac9773b01 (patch)
tree95c2d56b83f33f12b7bcd9ecf3f59320e6df4153 /development
parente885adb06d5713b43bb51a872f644f44de2ca624 (diff)
downloadslackbuilds-5331682a26ab2104f07e1dcc45a6857ac9773b01.tar.gz
python/pyflakes: Updated for version 0.5.0 (+new category)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/pyflakes/README16
-rw-r--r--development/pyflakes/pyflakes.SlackBuild70
-rw-r--r--development/pyflakes/pyflakes.info10
-rw-r--r--development/pyflakes/slack-desc19
4 files changed, 0 insertions, 115 deletions
diff --git a/development/pyflakes/README b/development/pyflakes/README
deleted file mode 100644
index 60e7585433..0000000000
--- a/development/pyflakes/README
+++ /dev/null
@@ -1,16 +0,0 @@
-PyFlakes a Lint-like tool for Python, like PyChecker. It is focused on
-identifying common errors quickly without executing Python code.
-
-Its primary advantage over PyChecker is that it is fast. You don't have
-to sit around for minutes waiting for the checker to run; it runs on most
-large projects in only a few seconds.
-
-The two primary categories of defects reported by PyFlakes are:
-* Names which are used but not defined or used before they are defined
-* Names which are redefined without having been used
-
-These can each take many forms. For example, PyFlakes will tell you when
-you have forgotten an import, mistyped a variable name, defined two functions
-with the same name, shadowed a variable from another scope, imported a module
-twice, or two different modules with the same name, and so on.
-
diff --git a/development/pyflakes/pyflakes.SlackBuild b/development/pyflakes/pyflakes.SlackBuild
deleted file mode 100644
index 01284f8684..0000000000
--- a/development/pyflakes/pyflakes.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyflakes
-
-# Copyright 2010 LukenShiro <lukenshiro@ngi.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyflakes
-VERSION=${VERSION:-0.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCFILES="PKG-INFO"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-python setup.py build
-python setup.py install --prefix=/usr/ --root=$PKG
-
-# Copy documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pyflakes/pyflakes.info b/development/pyflakes/pyflakes.info
deleted file mode 100644
index d1b512bb5f..0000000000
--- a/development/pyflakes/pyflakes.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyflakes"
-VERSION="0.4.0"
-HOMEPAGE="http://www.divmod.org/trac/wiki/DivmodPyflakes"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyflakes/pyflakes-0.4.0.tar.gz"
-MD5SUM="630a72510aae8758f48cf60e4fa17176"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
-APPROVED="dsomero"
diff --git a/development/pyflakes/slack-desc b/development/pyflakes/slack-desc
deleted file mode 100644
index 7cbf59ab9f..0000000000
--- a/development/pyflakes/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler--------------------------------------------------------|
-pyflakes: pyflakes (passive checker of Python programs)
-pyflakes:
-pyflakes: Pyflakes is a program to analyze Python programs and detect various
-pyflakes: errors. It works by parsing the source file, not importing it, so it
-pyflakes: is safe to use on modules with side effects. It's also much faster
-pyflakes: passive checker of Python programs.
-pyflakes:
-pyflakes:
-pyflakes:
-pyflakes: Homepage: http://www.divmod.org/trac/wiki/DivmodPyflakes
-pyflakes: