summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Ferenc Deak2011-11-09 20:22:07 +0100
committer Robby Workman2011-11-26 16:09:10 +0100
commit4f9a8266f962488c395bb0b52d8c2e2fb0f55510 (patch)
tree00b01975faa71c51814189b2a5d8d439a6c707db /development
parentc77efa0419d9b229f6a7beefd09d1ee7b9b7de8a (diff)
downloadslackbuilds-4f9a8266f962488c395bb0b52d8c2e2fb0f55510.tar.gz
development/ocaml: Updated for version 3.12.1.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/ocaml/README17
-rw-r--r--development/ocaml/configure.patch13
-rw-r--r--development/ocaml/ocaml.SlackBuild14
-rw-r--r--development/ocaml/ocaml.info10
-rw-r--r--development/ocaml/slack-desc2
5 files changed, 35 insertions, 21 deletions
diff --git a/development/ocaml/README b/development/ocaml/README
index 0eb8cd8c9c..bcdfc9020f 100644
--- a/development/ocaml/README
+++ b/development/ocaml/README
@@ -1,8 +1,9 @@
-Caml is a general-purpose programming language, designed with program safety
-and reliability in mind. It is very expressive, yet easy to learn and use.
-Caml supports functional, imperative, and object-oriented programming styles.
-The Objective Caml system is the main implementation of the Caml language.
-It features a powerful module system and a full-fledged object-oriented layer.
-It comes with a native-code compiler that supports numerous architectures, for
-high performance; a bytecode compiler, for increased portability; and an
-interactive loop, for experimentation and rapid development.
+Caml is a general-purpose programming language, designed with program
+safety and reliability in mind. It is very expressive, yet easy to learn
+and use. Caml supports functional, imperative, and object-oriented
+programming styles. The Objective Caml system is the main implementation
+of the Caml language. It features a powerful module system and a
+full-fledged object-oriented layer. It comes with a native-code
+compiler that supports numerous architectures, for high performance;
+a bytecode compiler, for increased portability; and an interactive loop,
+for experimentation and rapid development.
diff --git a/development/ocaml/configure.patch b/development/ocaml/configure.patch
new file mode 100644
index 0000000000..2f91abe106
--- /dev/null
+++ b/development/ocaml/configure.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2011-07-04 23:15:01.000000000 +0200
++++ configure 2011-11-05 15:17:01.946744829 +0100
+@@ -1600,6 +1600,10 @@
+ nativecccompopts="$nativecccompopts -fomit-frame-pointer";;
+ esac
+
++# Add additional flags from the environment
++bytecccompopts="$bytecccompopts $CFLAGS"
++nativecccompopts="$nativecccompopts $CFLAGS"
++
+ # Finish generated files
+
+ cclibs="$cclibs $mathlib"
diff --git a/development/ocaml/ocaml.SlackBuild b/development/ocaml/ocaml.SlackBuild
index 677774f1ac..d97021f342 100644
--- a/development/ocaml/ocaml.SlackBuild
+++ b/development/ocaml/ocaml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ocaml
-# Copyright 2007-2009 Ferenc Deak <ferenc.deak@gmail.com>
+# Copyright 2007-2011 Ferenc Deak <ferenc.deak@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ocaml
-VERSION=3.11.1
+VERSION=3.12.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -67,14 +65,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-./configure \
+patch < $CWD/configure.patch
+
+CFLAGS="$SLKCFLAGS" ./configure \
--prefix /usr \
--libdir /usr/lib${LIBDIRSUFFIX}/ocaml \
--host $ARCH-slackware-linux
-sed -i -e "s/\\(BYTECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
-sed -i -e "s/\\(NATIVECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
-
make world.opt
make install \
PREFIX=$PKG/usr \
@@ -88,6 +85,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changes INSTALL LICENSE README README.win32 Upgrading VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/ocaml-3.12-refman.html > $PKG/usr/doc/$PRGNAM-$VERSION/ocaml-refman.html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/ocaml/ocaml.info b/development/ocaml/ocaml.info
index 8044af5ebf..fc1b7c255d 100644
--- a/development/ocaml/ocaml.info
+++ b/development/ocaml/ocaml.info
@@ -1,10 +1,12 @@
PRGNAM="ocaml"
-VERSION="3.11.1"
+VERSION="3.12.1"
HOMEPAGE="http://caml.inria.fr"
-DOWNLOAD="http://caml.inria.fr/pub/distrib/ocaml-3.11/ocaml-3.11.1.tar.bz2"
-MD5SUM="fe011781f37f6b41fe08e0706969a89e"
+DOWNLOAD="http://caml.inria.fr/pub/distrib/ocaml-3.12/ocaml-3.12.1.tar.bz2 \
+ http://caml.inria.fr/pub/distrib/ocaml-3.12/ocaml-3.12-refman.html"
+MD5SUM="227a3daaedb150bf5037a3db01f5bf42 \
+ dbefdc669251e67a6b6fdd28fb6c8777"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Ferenc Deak"
EMAIL="ferenc.deak@gmail.com"
-APPROVED="dsomero"
+APPROVED="dsomero,Niels Horn"
diff --git a/development/ocaml/slack-desc b/development/ocaml/slack-desc
index fb8e65248f..a76204111c 100644
--- a/development/ocaml/slack-desc
+++ b/development/ocaml/slack-desc
@@ -7,7 +7,7 @@
|-----handy-ruler------------------------------------------------------|
ocaml: ocaml (A functional programming language)
-ocaml:
+ocaml:
ocaml: Caml is a general-purpose programming language, designed with program
ocaml: safety and reliability in mind. It is very expressive, yet easy to
ocaml: learn and use. Caml supports functional, imperative, and