summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Erik Hanson2010-08-16 05:09:43 +0200
committer Erik Hanson2010-08-16 05:09:43 +0200
commitce7f37d2d3b78b8bd881bb2a6d8a58f9a4865e58 (patch)
treef28b59887e71438b291850e81062b8fb6cb1cbfc /development
parentf4d3f60b946220a1ff3ef9d7046455251fe4ba72 (diff)
downloadslackbuilds-ce7f37d2d3b78b8bd881bb2a6d8a58f9a4865e58.tar.gz
development/PyOpenGL: Removed. Replaced with libraries/PyOpenGL.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/PyOpenGL/PyOpenGL.SlackBuild72
-rw-r--r--development/PyOpenGL/PyOpenGL.info10
-rw-r--r--development/PyOpenGL/README12
-rw-r--r--development/PyOpenGL/slack-desc19
4 files changed, 0 insertions, 113 deletions
diff --git a/development/PyOpenGL/PyOpenGL.SlackBuild b/development/PyOpenGL/PyOpenGL.SlackBuild
deleted file mode 100644
index e0af55f905..0000000000
--- a/development/PyOpenGL/PyOpenGL.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-## Written by hollywoodb (hollywoodb@fastmail.fm)
-
-## Feel free to use, modify, redistribute this script.
-## If you make changes please modify the "Written by"
-## so that I don't recieve emails about a script I
-## did not write. Thanks.
-
-# Modified by the SlackBuilds.org project
-
-NAME=PyOpenGL
-VERSION=3.0.0a5
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$NAME}
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $NAME-$VERSION
-tar -zxvf $CWD/$NAME-$VERSION.tar.gz
-cd $NAME-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$NAME-$VERSION
-install -m 0644 PKG-INFO documentation/{development,using}.html \
- $PKG/usr/doc/$NAME-$VERSION
-
-cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/PyOpenGL/PyOpenGL.info b/development/PyOpenGL/PyOpenGL.info
deleted file mode 100644
index fa06fecb7f..0000000000
--- a/development/PyOpenGL/PyOpenGL.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="PyOpenGL"
-VERSION="3.0.0a5"
-HOMEPAGE="http://pyopengl.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/pyopengl/PyOpenGL-3.0.0a5.tar.gz"
-MD5SUM="943c4d7d3d1d97cc7592e61d28918fd2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="hollywoodb"
-EMAIL="hollywoodb@fastmail.fm"
-APPROVED="rworkman,pprkut"
diff --git a/development/PyOpenGL/README b/development/PyOpenGL/README
deleted file mode 100644
index cd3fdd2a74..0000000000
--- a/development/PyOpenGL/README
+++ /dev/null
@@ -1,12 +0,0 @@
-PyOpenGL is the cross platform Python binding to OpenGL and related APIs.
-The binding is created using the SWIG wrapper generator, and is provided
-under an extremely liberal BSD-style Open-Source license.
-
-PyOpenGL includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3, WGL 4,
-and Togl (Tk OpenGL widget) 1.6. It also includes support for dozens of
-extensions (where supported in the underlying implementation).
-
-PyOpenGL is interoperable with a large number of external GUI libraries
-for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
-
-Requirements: pysetuptools (setuptools) -- build requirement only
diff --git a/development/PyOpenGL/slack-desc b/development/PyOpenGL/slack-desc
deleted file mode 100644
index 2761fff9c7..0000000000
--- a/development/PyOpenGL/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-PyOpenGL: PyOpenGL (cross-platform Python<->OpenGL bindings)
-PyOpenGL:
-PyOpenGL: PyOpenGL is the cross platform Python binding to OpenGL and related
-PyOpenGL: APIs. The binding is created using the SWIG wrapper generator, and is
-PyOpenGL: provided under an extremely liberal BSD-style Open-Source license.
-PyOpenGL: PyOpenGL includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3,
-PyOpenGL: WGL 4, and Togl (Tk OpenGL widget) 1.6. It also includes support for
-PyOpenGL: dozens of extensions (where supported in the underlying implementa-
-PyOpenGL: tion).
-PyOpenGL:
-PyOpenGL: