summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author LukenShiro2010-10-25 04:08:18 +0200
committer Erik Hanson2010-10-25 14:55:10 +0200
commitb50ce4827f10b0d9a33760dbb1c38a13b02c4c29 (patch)
tree90e07fe019f853b309c6d17c1f006afcf64a6ae8 /development
parentafda04164adf91e4a5b29ca949a028455c40a75f (diff)
downloadslackbuilds-b50ce4827f10b0d9a33760dbb1c38a13b02c4c29.tar.gz
development/numexpr: Added (numerical array expression evaluator)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/numexpr/README14
-rw-r--r--development/numexpr/numexpr.SlackBuild88
-rw-r--r--development/numexpr/numexpr.info10
-rw-r--r--development/numexpr/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/development/numexpr/README b/development/numexpr/README
new file mode 100644
index 0000000000..7d34e96b2d
--- /dev/null
+++ b/development/numexpr/README
@@ -0,0 +1,14 @@
+The numexpr package evaluates multiple-operator array expressions many times
+faster than NumPy can. It accepts the expression as a string, analyzes it,
+rewrites it more efficiently, and compiles it to faster Python code on the
+fly. It's the next best thing to writing the expression in C and compiling
+it with a specialized just-in-time (JIT) compiler, i.e. it does not require
+a compiler at runtime.
+
+Also, and since version 1.4, numexpr implements support for multi-threading
+computations straight into its internal virtual machine, written in C. This
+allows to bypass the GIL in Python, and allows near-optimal parallel
+performance in your vector expressions, most specially on CPU-bounded
+operations (memory-bounded were already the strong point of Numexpr).
+
+This requires numpy.
diff --git a/development/numexpr/numexpr.SlackBuild b/development/numexpr/numexpr.SlackBuild
new file mode 100644
index 0000000000..97187b33bd
--- /dev/null
+++ b/development/numexpr/numexpr.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for numexpr
+
+# Copyright 2010 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=numexpr
+VERSION=${VERSION:-1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# directory for python packages
+PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
+
+DOCFILES="ANNOUNCE.txt INSTALL.txt LICENSE.txt README.txt RELEASE_NOTES.txt"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS=$SLKCFLAGS python setup.py build install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Move documentation .pdf files and text files to avoid file duplication in
+# python directory
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/numexpr/numexpr.info b/development/numexpr/numexpr.info
new file mode 100644
index 0000000000..942812d94b
--- /dev/null
+++ b/development/numexpr/numexpr.info
@@ -0,0 +1,10 @@
+PRGNAM="numexpr"
+VERSION="1.4"
+HOMEPAGE="http://code.google.com/p/numexpr/"
+DOWNLOAD="http://numexpr.googlecode.com/files/numexpr-1.4.tar.gz"
+MD5SUM="e31594a3796f225292a1515637dfff9c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/development/numexpr/slack-desc b/development/numexpr/slack-desc
new file mode 100644
index 0000000000..923a69e87e
--- /dev/null
+++ b/development/numexpr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+numexpr: numexpr (Fast numerical array expression evaluator for Python)
+numexpr:
+numexpr: It evaluates multiple-operator array expressions many times faster
+numexpr: than NumPy can. It accepts the expression as a string, analyzes it,
+numexpr: rewrites it more efficiently, and compiles it to faster Python code.
+numexpr:
+numexpr: Homepage: http://code.google.com/p/numexpr/
+numexpr:
+numexpr:
+numexpr:
+numexpr: